Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jan_P_
Beginner
119 Views

Intel SGX Debugger (SDK 1.8) does not work for x64 enclaves on Win10 1607

Jump to solution

Hello,

I am trying to debug X64 enclave using Intel SGX Debugger from SDK 1.8 on Win 10 1607. The debugger never hits the breakpoint inside enclave even though the enclave code is executed and debug symbols for the enclave are shown as loaded in MS Visual Studio 2015. Is this a known limitation of SGX debugger?

 

Thanks,

Jan

0 Kudos

Accepted Solutions
119 Views

Intel® SGX debugger does not work for the X64 mode in the initial release of Windows 10 Anniversary Update (version 1607). Please, update the OS Build to 14393.479 or later.

More details on OS build numbers and corresponding KB articles are available at https://technet.microsoft.com/en-us/windows/release-info.aspx

Thanks,

Francisco

View solution in original post

5 Replies
Anusha_K_Intel
Employee
119 Views

Hi,

Set the breakpoint at the point where the ecall is made in the application code  then run the code using Intel SGX debugger and press the f10 key to reach the breakpoints inside the enclave. I am using the sgx 1.8 and x64 enclave it works.

Regards,

Anusha.

Jan_P_
Beginner
119 Views

Hi Anusha,

Are you using the same version od windows 10 as I am i.e. win 10 v1607? In the SDK 1.7 Release Notes document Intel states citation:"Intel® SGX debugger does not work for X64 mode on the Windows 10 Anniversary Update (version 1607)"

I am having this OS version and Win32 enclaves are with SDK 1.8 debuggable just fine. X64 seems not working in the same way as SDK 1.7. Should I update to another OS version or downgrade to Win7?

Thank you,

Jan

Anusha_K_Intel
Employee
119 Views

Hi,
I am using windows 10 pro v1511 , Intel SGX 1.8 and Visual studio 2015 professional. Please try changing your Os version. Yes it doesn't work on Windows 10 Anniversary Update 4. 

120 Views

Intel® SGX debugger does not work for the X64 mode in the initial release of Windows 10 Anniversary Update (version 1607). Please, update the OS Build to 14393.479 or later.

More details on OS build numbers and corresponding KB articles are available at https://technet.microsoft.com/en-us/windows/release-info.aspx

Thanks,

Francisco

View solution in original post

Jan_P_
Beginner
119 Views

I updated the system and confirm that with later releases the x64 SGX debugger works as expected. Thank you!