Community
cancel
Showing results for 
Search instead for 
Did you mean: 
you_w_
New Contributor III
258 Views

My SGX APP can not run in release mode

Jump to solution
Hello every one: When I build the enclave in release mode and signed it, I can't load it in my app. And this is the out put. Error: Unexpected error occurred. I find that if I set SGX_DEBUG_FLAG=1, this error occurred. sgx_create_enclave(ENCLAVE_FILE, SGX_DEBUG_FLAG, &token, &updated, &eid, NULL); The Developer Reference side : "The enclave needs to be signed with a white-listed key." I wonder if this is the reason. Thus How can I add my key to a white list. Thanks! you.w
0 Kudos
1 Solution
258 Views

Hi,

For release mode , you need to build with DisableDebug<1> option in Enclave.config.xml.

For whitelisting you need to follow the steps mentioned in below links:

1. https://software.intel.com/en-us/articles/intel-software-guard-extensions-product-licensing-faq

2.https://software.intel.com/en-us/forums/intel-software-guard-extensions-intel-sgx/topic/681473

Regards

Shivananda

 

View solution in original post

2 Replies
259 Views

Hi,

For release mode , you need to build with DisableDebug<1> option in Enclave.config.xml.

For whitelisting you need to follow the steps mentioned in below links:

1. https://software.intel.com/en-us/articles/intel-software-guard-extensions-product-licensing-faq

2.https://software.intel.com/en-us/forums/intel-software-guard-extensions-intel-sgx/topic/681473

Regards

Shivananda

 

View solution in original post

you_w_
New Contributor III
258 Views

Hi:

Thank you,Shivananda. So If I want to run in release mode, I need to get a production license from Intel. Is that  right ?

Best Rguard

you

Reply