Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Svart_K_
Beginner
91 Views

SGX Plugin for Eclipse not working

Hello,

I have tried to install the SGX Plugin in Eclipse following this instructions
https://download.01.org/intel-sgx/linux-1.6/docs/Intel_SGX_SDK_Installation_Guide_Linux_1.6_Open_Sou...

I have installed Eclipse Mars 4.5.2, and the PDE Plugin. Then I have build the SGX Plugin in the /opt/linux-sgx-master/Linux_SGXEclipsePlugin/ folder successfully. But when going into Eclipse -> Install New Software -> Add the .zip -> select SGX Eclipse Plugin (1.6.100.1) and then click on next, Eclipse does not continue but simply just keeps showing the loading icon!?

Have I missed something in the instructions?

Thanks for any help

0 Kudos
3 Replies
91 Views

Svart_K_
Beginner
91 Views

Thank you for the reply.

I have followed the instructions:

Which now, when selecting the archive in Eclipse, shows the SGX plugin version 1.6.100.v

Unfortunately when clicking the 'Next' button I still experience the same issue, that the Eclipse keeps loading without proceeding.

I don't see any error messages in the terminal. Is there another way to include the .zip archive or at least to debug the problem somehow?

 

Thank you

bohn__christian
Beginner
91 Views

Hi, 

I am trying to install the SGX plugin for Eclipse Oxygen, but the installation failed. The error message says that 'org.eclipse.cdt.ui' is required but could not be found. I have followed all the steps in the instructions, so what am I doing wrong here?

Thanks for any help.

Reply