Community
cancel
Showing results for 
Search instead for 
Did you mean: 
muye
Novice
114 Views

sgx_init_quote

Jump to solution

Hi,

When I install the sgx devlopment environment with the latest packages for remote attestation , sgx_init_quote  always returns 1, how can i correct it?    

ubuntu@sgx:    modinfo isgx
filename: /lib/modules/5.0.0-23-generic/kernel/drivers/intel/sgx/isgx.ko
license: Dual BSD/GPL
version: 2.11.0
author: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
description: Intel SGX Driver
srcversion: 87784B58E0AACD186EEF5B6
alias: acpi*:INT0E0C:*
depends:
retpoline: Y
name: isgx
vermagic: 5.0.0-23-generic SMP mod_unload

ubuntu@sgx:       apt list --installed | grep sgx

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libsgx-ae-epid/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-ae-le/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-ae-pce/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-ae-qe3/unknown,now 1.9.100.3-bionic1 amd64 [installed,automatic]
libsgx-aesm-ecdsa-plugin/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-aesm-epid-plugin/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-aesm-launch-plugin/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-aesm-pce-plugin/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-aesm-quote-ex-plugin/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-enclave-common/unknown,now 2.12.100.3-bionic1 amd64 [installed]
libsgx-epid/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-headers/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-launch/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]
libsgx-pce-logic/unknown,now 1.9.100.3-bionic1 amd64 [installed,automatic]
libsgx-qe3-logic/unknown,now 1.9.100.3-bionic1 amd64 [installed,automatic]
libsgx-quote-ex/unknown,now 2.12.100.3-bionic1 amd64 [installed]
libsgx-quote-ex-dev/unknown,now 2.12.100.3-bionic1 amd64 [installed]
libsgx-uae-service/unknown,now 2.12.100.3-bionic1 amd64 [installed]
libsgx-urts/unknown,now 2.12.100.3-bionic1 amd64 [installed]
sgx-aesm-service/unknown,now 2.12.100.3-bionic1 amd64 [installed,automatic]




0 Kudos

Accepted Solutions
muye
Novice
63 Views

It's very kind of you for you replay again. I   have fixed it. 

Steps are as follows:     Uninstall SGX PSW  ,disable SGX in BIOS ,reboot, enable SGX,reinstall PSW. 

 

Sincerely,

muye

View solution in original post

6 Replies
muye
Novice
103 Views

 

when i make my own RA, sgx_init_quote    returns  1.

 

 

 

JesusG_Intel
Moderator
94 Views

Hello muye,


Did you try running the RemoteAttestation sample in the SGX SDK?


Sincerely,

Jesus G.

Intel Customer Support


muye
Novice
87 Views

Infact ,I did my attestation and get the result GROUP_OUT_OF_DATE form IAS.  After I updated the newest  BIOS,  compiling is ok,but sgx_init_quote always returns 1 when running . Then removing all and reinstall sgx development environment does not help.

JesusG_Intel
Moderator
72 Views

Hello Muye,


After upgrading your BIOS, did you ensure that SGX is enabled? Execute cpuid | grep -i sgx


Sincerely,

Jesus G.

Intel Customer Support


muye
Novice
69 Views

Thank you for your replaying.   After executing    cpuid | grep -i sgx   ,it shows it is normal .


SGX: Software Guard Extensions supported = true
SGX_LC: SGX launch config supported = false
SGX capability (0x12/0):
SGX1 supported = true
SGX2 supported = false
SGX attributes (0x12/1):
SGX: Software Guard Extensions supported = true
SGX_LC: SGX launch config supported = false
SGX capability (0x12/0):
SGX1 supported = true
SGX2 supported = false
SGX attributes (0x12/1):
SGX: Software Guard Extensions supported = true
SGX_LC: SGX launch config supported = false
SGX capability (0x12/0):
SGX1 supported = true
SGX2 supported = false
SGX attributes (0x12/1):
SGX: Software Guard Extensions supported = true
SGX_LC: SGX launch config supported = false
SGX capability (0x12/0):
SGX1 supported = true
SGX2 supported = false
SGX attributes (0x12/1):

muye
Novice
64 Views

It's very kind of you for you replay again. I   have fixed it. 

Steps are as follows:     Uninstall SGX PSW  ,disable SGX in BIOS ,reboot, enable SGX,reinstall PSW. 

 

Sincerely,

muye

View solution in original post