Intel® Trusted Execution Technology (Intel® TXT)
For questions and discussion on Intel® Trusted Execution Technology

CVE - Vulnerabilities in TXE v1.1

JL_work
Beginner
852 Views

Hi,

I'm using a J1900 Bay Trail (15yr hardware support cycle 2013-2028) (IMB-150D) and my PCB provider says that I'm using the newest drivers like: TXE v1.1.4.

 

-I see in some INTEL-SA communications that TXE v1.1.4 is not supported and the currently supported version of TXE is v3:

 

"Note:  Firmware versions of Intel® ME 3.x thru 10.x, Intel® TXE 1.x thru 2.x and Intel® Server Platform Services 1.x thru 2.X are no longer supported, thus were not assessed for the vulnerabilities/CVEs listed in this Technical Advisory. There is no new release planned for these versions."

 

-This means that Intel only verifies the new vulnerabilities in the current supported TXE version 3 and we can say that TXE version 1.1.4 could be affected by what is described in the security advisories: INTEL-SA-00295 + INTEL-SA-00213 + INTEL-SA - 00185 + INTEL-SA-00125, but has not been tested/assessed by Intel. 


If the hardware is supported until 2028 but I cannot move to new Intel software versions, it is the same as saying that Intel software for my system has reached its EOL/EOS, so I cannot patch new vulnerabilities.

 

-Is there a place where I can check the latest version that can be installed in my J1900 Bay Trail (15yr hardware support cycle 2013-2028) (IMB-150D)?

 

0 Kudos
0 Replies
Reply