Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Andreas_Jensen
Beginner
115 Views

Bug in xggsvd? "Parameter 5 was incorrect on entry to DORMQR"

When running the program in single threaded mode I get the error message "Parameter 5 was incorrect on entry to DORMQR". The message is not present if I either run the program with multiple threads or if I compile it with reference LAPACK. My compiltervar settings are intel64 ilp64 and the program is compiled with

ifort testgsvd.f90 -lmkl_rt

testgsvd.f90:

program testgsvd

  implicit none
  integer*8 :: k, l, alpha(10), beta(10), iwork(20), info
  double precision :: A(10,20), B(10,20), U, V, Q, work(80)

  open(1, file="a.txt", action = "read")
  read(1, *) A
  open(2, file="b.txt", action = "read")
  read(2, *) B
  close(1)
  close(2)

  call dggsvd('N', 'N', 'N', 10_8, 20_8, 10_8, k, l, A, 10_8, B, 10_8, alpha, beta, U, 1_8, V, 1_8, Q, 1_8, work, iwork, info)

end program testgsvd

The matrices A and B are attached.

0 Kudos
3 Replies
Gennady_F_Intel
Moderator
115 Views

by another words, the issue exists when you link with sequential mode of MKL?

the example contains the ?ggsvd, but the title is about domgr.

why parameter info is INTEGER* 8?

when you link with mkl_rt - you use LP64 interface by the default.

 

Andreas_Jensen
Beginner
115 Views

Thanks for the fast reply.

by another words, the issue exists when you link with sequential mode of MKL?

No. The difference is just between

./a.out

and

OMP_NUM_THREADS=1 ./a.out 

the example contains the ?ggsvd, but the title is about domgr.

Yes. The call is to dggsvd, but the error message comes from dormqr. I can see that reference LAPACK doesn't even call that function so thats the reason why I suspect it to be an MKL problem.

why parameter info is INTEGER* 8?
when you link with mkl_rt - you use LP64 interface by the default.

Before I compile and execute, I run source PATHTOINTEL/bin/compilervars.sh intel64 ilp64 and I thought that would cause ilp64 mode when running programs linked with lmkl_rt. Since you asked, I've also tried to set export MKL_INTERFACE_LAYER=ilp64 but I still get the same error.

Gennady_F_Intel
Moderator
115 Views

Ok, thanks Andreas. I see the similar behaviour on my side too. we will check the cause of the problem. 

Reply