Community
cancel
Showing results for 
Search instead for 
Did you mean: 
k_higashi
Beginner
208 Views

I can't use oneMKL on visual studio

When I set Use oneMKL= Sequential in the Intel Libraries for oneAPI on Visual studio project property, I couldn't run the build.

I waited about 10 minutes after starting the build.
However, the build did not finish with the following displayed on the Output screen.
----
Rebuild started...
1>------ Rebuild All started: Project: TestOneMKL, Configuration: Release x64 ------
----

I attach a file that can verify this problem. (TestOneMKL.zip)

 

For oneAPI beta10, the build was completed in a few seconds!

I want to solve this problem and use the oneMKL library.
Please tell me the cause and countermeasures.

----
OS: Windows 10 Pro
Toolkit:
Microsoft Visual Studio 2019 Professional (ver.16.8.3)
Intel oneAPI 2021.1

CPU: Intel Core i7-1165G7 2.80GHz
Accelerator:Intel Iris Xe Graphics
driver ver.: 27.20.100.9030

 

Best regards.

0 Kudos
3 Replies
AbhishekD_Intel
Moderator
196 Views

Hi,


Thanks for reaching out to us.

As this thread is more related to MKL, we are moving this thread to Intel MKL Forum.



Warm Regards,

Abhishek


RahulV_intel
Moderator
171 Views

Hi,


The issue is reproducible. Build on VS hangs when "Use MKL" is set to parallel/sequential.


However, it does seem to work when I set the "Use MKL" as No and Additional include directories (Project property pages -> DPC++ ->General) path to MKL_ROOT/include


I have escalated this issue to the concerned team. Thanks for reporting this.


Regards,

Rahul


Gennady_F_Intel
Moderator
162 Views

Yes, we confirmed the issue and it escalated. We will keep this thread informed.


Reply