Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.

MKL 7.0 installation problems

I'm trying to install MKL 7.0 on a RH7.1 (2.4.2-2smp kernel) linux box.

I just downloaded l_mkl_p_7.0.017.tar, created an /opt/intel/licenses directory as root and put the license file there. Then ran the script from my download directory (as root). I used default locations for the install dir (/opt/intel), but the first time I ran the script I encountered an "db3 error(22)" so I added the --rebuilddb option to the rpm options. The install seems to continue normally ending with "Installation successful", but when I hit return the installer reports
"RPM reports that no version of Intel Math Kernel Library are installed", and then the installer starts over again.

When I run it again, but with default options all the way, I now get a failed dependency erro:

error: failed dependencies:
/bin/sh is needed by intel-mkl-7.0p-17

Any ideas as to what is going on?

BTW: When I tried running the installed on another linux box (a dual xeon running RH9 kernel 2.4.20) I just get a blank screen from the installer. Very strange.

0 Kudos
0 Replies