This is rather a simple convenience suggestion than an error-report. However, it would still be very appreciated if you could implement this simple change.
I noticed that almost all function declarations from header `mkl_pardiso.h` do only have unnamed arguments. The variable names are missing, only their types are provided.
While this is still valid C/C++ I would recommend you add the variable names because that makes it easier to read the function signature, especially as all parameters have mostly the same type `const MKL_INT *` or `const long long int *`.
Btw, in MKL's online-documentation for these functions the parameters are named. But always looking into the online-documentation is tedious if instead the IDE could tell me the name of the argument that I have to provide.
Thanks for reaching out to us.
>>This is rather a simple convenience suggestion than an error-report. However, it would still be very appreciated if you could implement this simple change.
Yeah sure, we will let the concerned development team know about this issue. we are working on it, we will get back to you soon.
We have forwarded this issue to the development team and this would be implemented in the future releases of oneAPI. Since the issue is taken care of, could you please confirm if we can go ahead and close this thread from our end?
Thanks for the confirmation.
Please post a new question if you need any additional assistance from Intel as this thread will no longer be monitored.
Have a Nice Day!