Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Petros_Mamales
Beginner
573 Views

OMP: Warning #90:..

Hi,

Just downloaded and installed w_mkl_11.0.1.119.exe

After running the first test I get the - bundle of- :

OMP: Warning #90: ittnotify: Lookup of “__itt_<function>”
function in <installdir><redistlibpath>\pdbx.dll library failed.

Looking at the documentation, I see I have to ignore it. My question is how can I get rid of it?

(vs2010, win7 64bit ).

Thank you very much in advance,

P-

0 Kudos
52 Replies
Gennady_F_Intel
Moderator
440 Views

at the first glance the work around of this problem you can see following this link: http://software.intel.com/en-us/forums/topic/285302

Andrey_C_Intel1
Employee
440 Views

Have you tried the environment variable KMP_WARNINGS=off ?  It should make the OpenMP RTL to not issue any warnings.

Regards,
Andrey

Petros_Mamales
Beginner
440 Views

Gennady, Andrey,

Thank you very much for your help

P-

Petros_Mamales
Beginner
440 Views

Andrey,

What do you mean by "environment variable KMP_WARNINGS=off" ?

I looked in my environment variables and there is no environment variable KMP_WARNINGS (win7, 64bit).

Is this a setting in vs2010 ? Should I do it programmatically ( I really hope no)

(the parallel debug trick to off failed to silense the omp warnings).

Thank you in advance,

P-

Andrew_Smith
New Contributor II
440 Views

You need to add environment variable KMP_WARNINGS youself. Alternatively call kmp_set_defaults("KMP_WARNINGS=0") if using Fortran

Petros_Mamales
Beginner
440 Views

Hi Andrew,

Thank you for coming back to me .

Petros_Mamales
Beginner
440 Views

Andrew,

It does not seem to work ! tried woith value off and with value 0. (restarted th vs2010).

Any other suggestion ?

Petros_Mamales
Beginner
440 Views

Also, using c++.

Andrey_C_Intel1
Employee
440 Views

I am sorry, there is a problem in the OpenMP RTL with this warning (it is issued before we turn the warnings off, so we cannot disable it at the moment).  We will work on the problem and hopefully solve it in the next release of the library.

- Andrey

Petros_Mamales
Beginner
440 Views

Thank you Andrey,

P-

Olga_M_Intel
Employee
440 Views

Petros,

Could you please check what OpenMP library version you run your test with?

Set environment variable KMP_VERSION=1 and run your test. And see the output.

Thank you.

Petros_Mamales
Beginner
440 Views

Hi Olga,

I am really only using OpenMP through mkl. My (c++) program does not use openmp.

I am using intel c++ compiler 12.1 for win (7 64bit) with 64bit builds.

Will get back to you,

Thank you very much for your effort to help.

P-

Petros_Mamales
Beginner
440 Views

Hi Olga,

I inserted the env. variable you asked me to. Also inserted the KMP_WARNINGS=0 and disabled openMP support from my compiler (c++ intel 12.1 with c++0x enabled).

Still getting the warnings though..

I don't know if this helps but when I put the warnings as "off" (instead of off) I got the following additional message :

OMP: Hint: Use "0", "FALSE". ".F.", "off", "no" as false values, "1", "TRUE", ".T.", "on", "yes" as true values.
OMP: Warning #20: KMP_WARNINGS=""off"": Wrong value, boolean expected.
OMP: Hint: Use "0", "FALSE". ".F.", "off", "no" as false values, "1", "TRUE", ".T.", "on", "yes" as true values.
Intel(R) OMP Copyright (C) 1997-2011, Intel Corporation. All Rights Reserved.
Intel(R) OMP version: 5.0.20110606
Intel(R) OMP library type: performance
Intel(R) OMP link type: dynamic
Intel(R) OMP build time: 2011-06-07 02:07:15 UTC
Intel(R) OMP build compiler: Intel C++ Compiler 12.0
Intel(R) OMP alternative compiler support: yes
Intel(R) OMP API version: 3.0 (200805)
Intel(R) OMP tracefile support: no
Intel(R) OMP dynamic error checking: no
Intel(R) OMP helper thread support: yes
Intel(R) OMP thread affinity support: not used
Intel(R) OMP debugger support version: 1.1
Intel(R) OMP Intel(R) RML support: not using

Also, tried these as both user and system environment variables - just in case..

Thank you for your help,

Petros

SergeyKostrov
Valued Contributor II
440 Views

Hi Petros, Let me answer these questions: >>Is this a setting in vs2010 ? No. Visual Studios do not set any OpenMP environment variables. >>Should I do it programmatically ( I really hope no) You can do it programmatically, if it really needs to be done, and here is a small example in a C language: ... int iRetCode = _tputenv( _T("KMP_WARNINGS=off") ); if( iRetCode == 0 ) _tprintf( _T("KMP_WARNINGS=%s\n"), _tgetenv( _T("KMP_WARNINGS") ) ); else _tprintf( _T("Error: Failed to Set Environment Variable KMP_WARNINGS\n") ); ...
Olga_M_Intel
Employee
440 Views

Hi Petros,

It looks like you are using a quite old compiler and old OpenMP library. It is dated

Intel(R) OMP version: 5.0.20110606

The problem with Warning #90 was fixed in the OpenMP library version 20111108. It is available in the Compiler 12.1 Update 8 (Intel(R) C++ Composer XE 2011 Update 8).

Regarding the Warning #20 and hints I would say this is expected behavior because you inserted extra quotes in the variable value.

The correct syntax is

KMP_WARNINGS=off

KMP_WARNINGS=0

etc. ... without quotes.

Hope it helps you.

Thank you.

 

Petros_Mamales
Beginner
440 Views

Olga,

But I amnotusing openMP with my compiler in my c++ program - the flag is unchecked. I thought these messages are coming from the mkl openMP library. This is the command line from vs2010 :

/Zi /nologo /W3 /MP /Od /D "WIN32" /D "_DEBUG" /D "_CONSOLE" /D "_SCL_SECURE_NO_WARNINGS" /D "_CRT_SECURE_NO_WARNINGS" /D "BOOST_UBLAS_SHALLOW_ARRAY_ADAPTOR" /D "_UNICODE" /D "UNICODE" /EHsc /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Qstd=c++0x /Fp"x64\Debug\test_libRandom.pch" /Fa"x64\Debug\" /Fo"x64\Debug\" /Fd"x64\Debug\vc100.pdb"

Sergey,

Thank you, had figured out meanwhile.

Olga_M_Intel
Employee
440 Views

Petros Mamales wrote:

I amnotusing openMP with my compiler in my c++ program - the flag is unchecked. I thought these messages are coming from the mkl openMP library.

Yes, the MKL uses the OpenMP library. If you installed the MKL as standalone but not as a part of the Composer then the MKL should have installed libraries it depends on (like OpenMP library). MKL 11.0 installation package should contain the right version of the OpenMP library that has the fix for the warnings. But it looks like when your test calls the MKL it finds some old version of the OpenMP library (that was most likely installed with the old version of the compiler).

Petros_Mamales
Beginner
440 Views

All this is very confusing. Especially in light of the suggestion I was given in the forum, at an earlier question, to not mix the mkl omp library and the c++ provided one.

I installed mkl 11 as part of my mkl support's update ( my composer support has expired ). I really don't understand what I have to do. Is there a way to reinstall mkl and bypass the libraries that it finds from the composer installation ?

It is really annoying, what is happenning, especially when you try to debug.

SergeyKostrov
Valued Contributor II
440 Views

>>...It is really annoying, what is happenning, especially when you try to debug. Petros, When you're debugging in a Visual Studio please take a look at Output Window and find a section with a list of loaded DLLs ( they are always with full paths ). That verification could help you to understand what Intel DLLs are actually loaded and used by your application. Let me know if you need a small example on how it looks like, or post everything from Output Window ( when debugging! ) for our review.
Petros_Mamales
Beginner
210 Views

OLga,

(typical example)

ittnotify: Lookup of "__itt_stack_callee_leave" function in "C:\Program Files (x86)\Intel\Parallel Studio 2011\Composer SP1\redist\intel64\compiler\pdbx.dll" library failed.

And now that I know it, what do I do with ir ?

ps: The onlky dll loaded should be the one from mkl . If, as you say, this one is properly fixed, since I am using the latest and greatest one, then I should not see the messages.

Alas, no, the installation opted for not installing the newest dll because it found another one (older !! and therefore not fixed!!) , which chose to mantain so that other parallel studio utilities do not break down. Understood as conceivable.

Eh, well maybe the iwhole distribution model has some issues ?

Reply