Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Zoltan_K_
Beginner
96 Views

Octave 3.8.1 with MKL

I am trying to rebuild GNU Octave  with the Intel MKL on Ubuntu 14.04

uname -a

Linux zoli-Precision-WorkStation-T3500 3.13.0-27-generic #50-Ubuntu SMP Thu May 15 18:06:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

 

base on the description:

https://software.intel.com/en-us/articles/using-intel-mkl-in-gnu-octave

The only thing I haven't done is to edit the  configure.in file since there is no such file in the source directory of Octave 3.8.1. But this has something to do with fft which I don't need now anyway (I guess it's not a problem).

Having set the enviroment variables (CC, CXX, F77, CFLAGS, CPPFLAGS, LDFLAGS) I run configure with the suggested parameters and I get the following error:

checking whether ifort has the intrinsic function ISNAN... yes
checking whether ifort generates correct size integers... no
configure: error: your Fortran compiler must have an option to make integers the same size as octave_idx_type (int).  See the file INSTALL for more information.

I have installed both the Intel C++ and Fortran compilers (l_ccompxe_2013_sp1.3.174 and l_fcompxe_2013_sp1.3.174) with only the 64 bit option.

SInce the error message refers to Fortan I posted this problem here but not sure if it is really the problem of the Fortran compiler.

Could anyone help me please?

 

 

 

 

 

0 Kudos
3 Replies
Steven_L_Intel1
Employee
96 Views

I've moved this over to the MKL forum as folks there may be more familiar with this. I will comment that Intel Fortran's default integers are the same as C int, so maybe you added an option to change it that isn't shown in the article.

Michael_J_3
Beginner
96 Views

Were you able to figure this out?  I was using ifort and icc as well.

huang__astone
Beginner
96 Views

I've got the same issue while configuring octave 4.2.0, using parallel_studio_xe_2017_update1 and l_mkl_2017.0.098.

./configure --with-blas="-Wl,--start-group -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -Wl,--end-group -liomp5 -lpthread" --with-lapack="-Wl,--start-group -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -Wl,--end-group -liomp5 -lpthread" --enable-fortran-calling-convention=gfortran

uname -a: Linux ### 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Did you find a solution?

Reply