Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yang__xiaodong
Beginner
1,304 Views

PARDISO compatibility problem with new version OPENMP

Following runtime warning shows up when using the 2020 version of Intel fortran compiler along with MKL pardiso solver:

OMP: Info #273: omp_get_nested routine deprecated, please use omp_get_max_active_levels instead.

A parallel version of frac algorithm is selected by setting iparm(2)=3. No warning shows when iparm(2) has the default value 2.

It may be a compatibility problem and not fatal.

By the way, is there any way to suppress this warning before an update comes out? It's annoying when I frac matrices a lot.

0 Kudos
10 Replies
Kirill_V_Intel
Employee
1,302 Views

Hello,

We've already got notified about this particular issue.The warning is not fatal, but for sure we are going to fix it on our side. 

For clarity, could tell us the exact version of the compiler (for example, from ifort --version) and the way you link your application with MKL and OpenMP library? We'll look for workaround to suppress the warnings meanwhile.

Thanks,
Kirill

yang__xiaodong
Beginner
1,302 Views

Sure, I'm using the newest version of Fortran compilier

Intel(R) Visual Fortran Intel(R) 64 Compiler for applications running on Intel(R) 64, Version 19.1.0.166 Build 20191121

(the 2020 initial release of Parallel Studio)

in Windows 10, and the Fortran program I wrote is linked to MKL by /Qmkl:parallel option.

Kirill_V_Intel
Employee
1,302 Views

Hello!

I have the following suggestions:

1. Try to call kmp_set_warnings_off() to turn all warnings off at runtime (you can switch them on if you want by kmp_set_warnings_on(()) in your code around PARDISO.

2. Try to set env. variable KMP_WARNINGS to 0. This should also work but it has a corner case: if omp_get_nested is the very first call to OMP so that OMP library is not initialized prior to this call, it won't work..

Unfortunately, I was not able to reproduce the issue so let me know if my suggestions work.

Best,
Kirill

 

Gennady_F_Intel
Moderator
1,302 Views

I still don't reproduce the problem on my side: win10, 64it, MKL 2020, ifc ( intel fortran compiler v.19.1). Please see the log:

1)

MKLForums\u843114>ifort 

Intel(R) Visual Fortran Intel(R) 64 Compiler for applications running on Intel(R) 64, Version 19.1.0.166 Build 20191121

Copyright (C) 1985-2019 Intel Corporation.  All rights reserved.

ifort: command line error: no files specified; for help type "ifort /help"

2)

MKLForums\u843114>ifort /Qmkl pardiso_sym_f90.f90

Intel(R) Visual Fortran Intel(R) 64 Compiler for applications running on Intel(R) 64, Version 19.1.0.166 Build 20191121

Copyright (C) 1985-2019 Intel Corporation.  All rights reserved.

 

ifort: NOTE: The Beta evaluation period for this product ends on 11-oct-2018 UTC.

Microsoft (R) Incremental Linker Version 14.00.24215.1

Copyright (C) Microsoft Corporation.  All rights reserved.

-out:pardiso_sym_f90.exe

-subsystem:console

-libpath:C:\Apps\Intel2020\compilers_and_libraries\windows\mkl\lib\intel64_win

pardiso_sym_f90.obj

Jones__Andrew
Beginner
1,302 Views

I observe a similar problem when using the DSS interface to PARDISO if I specify the MKL_DSS_METIS_OPENMP_ORDER option when calling dss_reorder(). I am using the Microsoft Visual Studio 2017 C++ compiler, and the messages

OMP: Info #273: omp_get_nested routine deprecated, please use omp_get_max_active_levels instead.

  and

OMP: Info #273: omp_set_nested routine deprecated, please use omp_set_max_active_levels instead.

are displayed in a console window regardless of whether I compile the C++ code using OpenMP. The results are correct in both cases, but using MKL_DSS_METIS_OPENMP_ORDER yields significant performance improvement.

Chacon__Alexis
Beginner
1,302 Views

Hello  Kirill,

I have also found similar problem than the one described above, in using PARDISO functions in C++ to solving a System of linear equations into a OpenMP parallized loop. I got: 

OMP: Info #274: omp_get_nested routine deprecated, please use omp_get_max_active_levels instead.

I am using the version of MKL library of 2020,  /opt/local/intel_studio_xe_2020/ in linux in a server with:

NAME="Ubuntu"
VERSION="18.04.4 LTS (Bionic Beaver)"

ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.4 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

My program gets, Segmentation fault (core dumped) and stop to run.

Note, however, once i compile this in my Mac Book Pro the same program, does not have any issue in compiling neither running or exectuting.

Could you please have any advise on that refer? I would appreciate very much your help and if you could send me an email too or link where this issue can be solved.

Best,

Alexis

 

 

 

 

 

weinberg__david
Beginner
1,302 Views

I can reproduce this issue.  So I have the latest IVF and MKL for 2020 UPDATE 1 running x64 Windows 10.   Using call kmp_set_warnings_off() seems to have fixed the issue. 

 

marcsolal
Beginner
980 Views

I have same issue too. I just updated to the 2020 version of mkl and compiler. I am running paradiso inside a loop which is parallelized using openmp. I will use kmp_set_warnings_off()  but I hope intel will fix this issue soon. I do not want to miss other important warnings.

Ian_K_
Beginner
670 Views

I am still seeing this issue with Intel(R) Visual Fortran Compiler 19.1.3.311 [IA-32] just released.  I am using PARDISO and OPENMP elsewhere.  Changing IPARM(2) does not resolve the issue.

Any suggestions?

Gennady_F_Intel
Moderator
659 Views

yes, the fix of this issue is only in a progress and not available in the current ( latest ) version of mkl. We will update this thread when the fix will be released. As a workaround for the issue you may try to call kmp_set_warnings_off() as David and Kirill recommended above.

Reply