Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
53 Views

unable to find @rpath/libiomp5.dylib

I am new to MKL on Mac. 

I am running code in Fortran as follows: 

ifort -o name.x -fast -mkl program.f90

and I get the following error 

ipo: warning #11012: unable to find @rpath/libiomp5.dylib

I tried looking online to find a solution but I could find anything straight forward. 

 

The closest I got to a solution is to do the following wich is without '-fast' option 

ifort -o name.x -mkl program.f90 -Wl,-rpath,${MKLROOT}/lib -Wl,-rpath,$MKLROOT/../compiler/lib/

This works but when I do the following I get the same error 

ifort -o name.x -fast -mkl program.f90 -Wl,-rpath,${MKLROOT}/lib -Wl,-rpath,$MKLROOT/../compiler/lib/

ipo: warning #11012: unable to find @rpath/libiomp5.dylib

How can I add the path?

0 Kudos
1 Reply
Highlighted
Moderator
53 Views

this shared object is part of iItel compiler package. in the case, if you have a compiler installed on your system, you may call compilervars script to set all needed paths. see more details follow this link: https://software.intel.com/en-us/cpp-compiler-developer-guide-and-reference-specifying-the-location-of-compiler-components-with-compilervars.

in the case, if you use the standalone package of mkl, then use mklvars.sh scrpts for this purpose. 

0 Kudos