Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.
6973 Discussions

x86GPUs occurs problem that douple precision is not supported

qingfeng
Beginner
1,383 Views

when I use MKL on x86 GPU, compilation can pass but the double precision is not supported when executing. So can I solve it ?

qingfeng_0-1635414349995.png

 

0 Kudos
1 Solution
VidyalathaB_Intel
Moderator
1,142 Views

Hi,


Thanks for providing the details.


The following GPUs are the only supported devices for using intel oneMKL as of now.


Intel® HD Graphics

Intel® UHD Graphics for 9th, 10th, and 11th Gen Intel® Processors

Intel® Iris® Plus Graphics

Intel® Iris® Xe Graphics

Intel® Iris® Xe Max Graphics

Intel® Iris® Graphics

Intel® Iris® Pro Graphics



Please refer to the below link for more details.

https://www.intel.com/content/www/us/en/developer/articles/system-requirements/oneapi-math-kernel-library-system-requirements.html


>> Device: Vivante OpenCL Device CC8400.6305.0000... but the double precision is not supported when executing


We suggest you try the supported devices.

Please do let us know if you face any issues with the supported devices (Intel GPU's) if there is nothing else please confirm whether we can close this thread from our end.


Regards,

Vidya.


View solution in original post

0 Kudos
8 Replies
qingfeng
Beginner
1,375 Views

I went to check the calling interface of the function and defined the data type of the input parameter as double, but my GPU is x86

0 Kudos
VidyalathaB_Intel
Moderator
1,352 Views

Hi,


Thanks for reaching out to us.


>>my GPU is x86


Could you please let us know which GPU you are using for running your program along with your OS environment details and MKL version?


>>the calling interface of the function and defined the data type of the input parameter as double,


It would be a great help if you provide us with a sample reproducer so that we can try it from our end.


Please refer to the below link for more details regarding the system requirements of Intel oneMKL

https://www.intel.com/content/www/us/en/developer/articles/system-requirements/oneapi-math-kernel-library-system-requirements.html


Regards,

Vidya.


0 Kudos
VidyalathaB_Intel
Moderator
1,317 Views

Hi,


Reminder:

As we have not heard back from you, do you have any updates? Please provide us with a sample reproducer and the above-mentioned details so that we can work on it from our end.


Regards,

Vidya.


0 Kudos
qingfeng
Beginner
1,275 Views
Hi  Vidya
 
 
 
I looked at the source code and there is a check for double determinations. 
qingfeng_0-1636337424257.png

 

Another error occurs when I comment out the check item. It is " terminate called after throwing an instance of 'cl::sycl::memory_allocation_error'"
0 Kudos
VidyalathaB_Intel
Moderator
1,246 Views

Hi,


Thanks for providing the details of your code.


We tried it from our end and were able to run the block_cholesky_decomposition successfully.


Below are the environment details on which I have tried.


OS: Ubuntu 18.04

MKL: 2021.4.0

Device: Intel(R) UHD Graphics 630 [0x3e98] 


>>can pass but the double precision is not supported when executing. So can I solve it


As per the system requirements, Gen9 or higher versions of GPU are supported.


Please refer to the below link for more details

https://www.intel.com/content/www/us/en/developer/articles/guide/intel-graphics-developers-guides.html


Could you please let us know which GPU you are using for running your program and also MKL version?


Regards,

Vidya.


0 Kudos
qingfeng
Beginner
1,207 Views

hi Vidya

Thanks for your reply.

Below are the environment details on which I have tried.

OS: 18.04.1-Ubuntu

MKL: 2021.4.0

Device:  Vivante OpenCL Device CC8400.6305.0000

 

Regards,

qingfeng.

0 Kudos
VidyalathaB_Intel
Moderator
1,143 Views

Hi,


Thanks for providing the details.


The following GPUs are the only supported devices for using intel oneMKL as of now.


Intel® HD Graphics

Intel® UHD Graphics for 9th, 10th, and 11th Gen Intel® Processors

Intel® Iris® Plus Graphics

Intel® Iris® Xe Graphics

Intel® Iris® Xe Max Graphics

Intel® Iris® Graphics

Intel® Iris® Pro Graphics



Please refer to the below link for more details.

https://www.intel.com/content/www/us/en/developer/articles/system-requirements/oneapi-math-kernel-library-system-requirements.html


>> Device: Vivante OpenCL Device CC8400.6305.0000... but the double precision is not supported when executing


We suggest you try the supported devices.

Please do let us know if you face any issues with the supported devices (Intel GPU's) if there is nothing else please confirm whether we can close this thread from our end.


Regards,

Vidya.


0 Kudos
VidyalathaB_Intel
Moderator
1,131 Views

Hi,


Thanks for accepting our solution.

As the issue is resolved we are closing this thread. Please post a new question if you need any additional information from Intel as this thread will no longer be monitored.


Have a Nice Day!


Regards,

Vidya.


0 Kudos
Reply