Community
cancel
Showing results for 
Search instead for 
Did you mean: 
donnyb
Beginner
131 Views

Error Can not find libtbb_debug.so.2

everytime I try to compile a program with code::blocks it gives me the above error in the console.
I tried running the .sh file to set the paths, but none of that works.
If someone is using ubuntu and code::blocks maybe they could help step by step.
I have done my homework on the bash in the .sh file and understand it, but it is not setting up the paths.
I need someone who can help me one on one with this problem if possible, because if not I am going to have to re-install ubuntu as it is not giving me that error even if I just try and call a pthread.
Thanks,
Donald
0 Kudos
3 Replies
Anton_Pegushin
New Contributor II
131 Views

Hi, on Linux OSes instead of executing the tbbvars.sh script, you need to source it. In bash it's done by:
`. /opt/intel/tbb..(path to the appropriate tbbvars.sh script)` (Note the dot and space in the beginning '. ')
donnyb
Beginner
131 Views

I did source it ine my .bashrc file

source ///.bashrc

unfortunally it does not apply to the whole system and when I try to compile with my code::blocks compiler it can not find the file.
I tried setting the var in the code::Blocks and that did not work either.
I am thinking if I source it in the beggining of the bootup cycle maybe I could get those varablies to apply to the whole operating system, but I am not sure which file to put it in.
It is the code blocks file I am having trouble with.
Thanks for any help in advance thanks.
Anton_Pegushin
New Contributor II
131 Views

Hello, your ~/.bashrc file should contain a line similar to:
source /opt/intel/tbb/3.0/bin/tbbvars.sh
(you also can use '. ' - dot and space instead of 'source')
in this case, when you start a bash session/process tbbvars.sh will get sourced and appropriate environment variables will be set. Is this what you have on your side?
Reply