Intel® oneAPI Threading Building Blocks
Ask questions and share information about adding parallelism to your applications when using this threading library.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Test suite failures in TBB 3.0.035

bicatali
Beginner
84 Views
Hi,

A few tests from the TBB test suite are failing with gcc 4.5:

* ./test_tbb_version.exe
Error: version strings do not match.
Expected "TBB: BUILD_GLIBC" not found in:
-pc-linux-gnu --disable-altivec --disable-fixed-point --without-ppl --without-cloog --disable-lto --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --enable-multilib --enable-libmudflap --disable-libssp --enable-libgomp --enable-cld --with-python-dir=/share/gcc-data/x86_64-pc-linux-gnu/4.5.0/python --disable-libgcj --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --with-bugurl=hmake[1]: *** [test_tbb_plain] Error 1

* ./test_compiler.exe
Test failed at iteration i=256
../../src/test/test_compiler.cpp:53, assertion i == 256: bool representation differs from {0,1} set

And some are just slower:
* ./test_concurrent_vector.exe 1:4
Warning: grow_by is pathetically slow: t2==0.112649 t128=0.170042 k=1.50948

* ./test_concurrent_vector_v2.exe 1:4
Warning: grow_by is pathetically slow: t2==0.152793 t128=0.190662

This is on an Opteron 8x4 cores, Gentoo Linux, gcc 4.5.0, glibc-2.11.2, Linux kernel 2.6.29

Thanks,
Sebastien


0 Kudos
3 Replies
Vladimir_P_Intel2
84 Views
HiSebastien,

Thanks for notification!

* ./test_tbb_version.exe: could you check that following command return one line only.

g++ -v &1 | grep 'gcc.*version'

it looks it returns full output from `g++ -v` command
* ./test_compiler.exe: this is the test optimization issue and itwill be addressed in future releases, it can be ignored here.
not sure about the rest of warnings.
--Vladimir
bicatali
Beginner
84 Views
Here we go:

cayenne ~ # g++ -v &1 | grep 'gcc.*version'
Configured with: /var/tmp/portage/sys-devel/gcc-4.5.0/work/gcc-4.5.0/configure --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.0 --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.0/include --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.0 --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.0/man --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.5.0/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.0/include/g++-v4 --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-altivec --disable-fixed-point --without-ppl --without-cloog --disable-lto --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --enable-multilib --enable-libmudflap --disable-libssp --enable-libgomp --enable-cld --with-python-dir=/share/gcc-data/x86_64-pc-linux-gnu/4.5.0/python --disable-libgcj --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.5.0 p1.2, pie-0.4.5' --enable-shared --disable-static
gcc version 4.5.0 (Gentoo 4.5.0 p1.2, pie-0.4.5)


Vladimir_P_Intel2
84 Views
thanks, it looks that "--with-pkgversion" was caught by grep filter. This needs to be fixed in our build scripts.
--Vladimir
Reply