Intel vPro® Platform
Intel Manageability Forum for Intel® EMA, AMT, SCS & Manageability Commander
2762 Discussions

AMT does connect to wifi profiles when OS is down

FFern4
Novice
2,225 Views

Hi

 

I have Intel EMA installed and working for a long time.  I have several AMT profiles for several endpoints groups, and the option "Enable WIFI connection in all operating system power states (S0-S5)" works fine at endpoints with Intel AMT versions 11.8.x and 12.0.90. I mean the CIRA tunnel is connected when windows is down and the PC is powered. Intel AMT is able to connect to the WiFi access points configured as WiFi profiles

 

Using the same endpoint groups and AMT profiles, I have added some new endpoints with AMT versions 15.0.41 and 16.0.15.

 

Devices have been provisioned properly (ACM mode using WiFi interfaces), CIRA is established whe Windows is running, but the problem is that AMT does not connect to WiFi when Windows is down, so I cannot wake up those PC´s remotely using AMT capabilities.

 

As I have said, older PC´s using the same AMT profile and WiFi profiles work fine

The options:

[x] Enable synchro of Intel AMT with host platform WIFI profiles
[x] Enable WIFI connection in all operating system power states (S0-S5)

are enabled at the WiFi profiles

 

I have checked BIOS configuration, but I don´t find anything that could be the source of the problem

 

I have noticed that at some devices, if I power off the device while the power supply is connected, the CIRA connection remain established, but if the power supply is disconnected and reconnected, the CIRA connection is never established again until the device is powered up and Windows is running

 

Do you know if there is any difference at the new AMT versions that could cause the problem?

 

Regards and thanks in advance

 

Fernando

0 Kudos
19 Replies
SergioS_Intel
Moderator
2,216 Views

Hello FFern4,


Thank you for contacting Intel Customer Support.

 

 Please help us by providing more information in order to understand your issue:

 

 1. Can you please let us know on how many systems are you getting this issue? What is the model of those systems?

 

 2. What version of EMA are you running on the affected systems?

 

 3. You mentioned that "older PC´s using the same AMT profile and WiFi profiles work fine". What are the model of those systems and what EMA version are you running on those?


4. When did you start noticing this issue?

 

 Looking forward to your response.

 

 Best regards,

 Sergio S.

 Intel Customer Support Technician


0 Kudos
FFern4
Novice
2,210 Views

Hi

 

Find my answers below

 

 1. Can you please let us know on how many systems are you getting this issue? What is the model of those systems?

 

I have tested 3 different systems. They are the following

  • HP EliteBook 840 14 inch G9 Notebook PC i5-1250P AMT v16.0.15
  • HP EliteBook 640 14 inch G9 Notebook PC i7-1270P AMT v16.0.15
  • HP ZBook Studio 15.6 inch G8 Mobile Workstation PC i9-11950H AMT v15.0.41

 

 2. What version of EMA are you running on the affected systems?

 

EMA is the latest version, 1.8.0

 

 3. You mentioned that "older PC´s using the same AMT profile and WiFi profiles work fine". What are the model of those systems and what EMA version are you running on those?

 

I am using the same EMA server for all the devices. The "old" and the news devices are in the same endpoint workgroups, with the same AMT profiles

 

  • NUC7i5DNHE i5-7300U AMT v11.8.86 
  • HP EliteBook x360 1040 G6 i5-8365U AMT v12.0.90 
  • HP Elite Slice i5-6500T AMT v11.8.92

Although NUC and HP Slice have ethernet connections, they work through WiFi when Ethernet cable is not connected

 

4. When did you start noticing this issue?

I received the new devices yesterday. I added them to the EMA server and the behaviour was the mentioned since the begining. Devices connect to the WiFi Access Point if Windows is powered off with the power supply attached to the device. If you disconnect the power supply and connect again, or Windows is powered off running from battery and connect the power supply later, AMT does not connect to the WiFi

 

Regards and thanks for support

 

Fernando

 

0 Kudos
SergioS_Intel
Moderator
2,204 Views

Hello FFern4,


Thank you for the additional information, please allow us to check it and we will get back to you.

 

 Best regards,

 Sergio S.

 Intel Customer Support Technician


0 Kudos
SergioS_Intel
Moderator
2,195 Views

Hello FFern4,

 

 Thank you for waiting for your updates. 

 

 We do recommend checking with the laptop manufacturer for any updates to complete on the systems (BIOS, AMT firmware) so he can complete those and test the environment.

 

 This link can help: https://support.hp.com/gb-en/drivers/selfservice/hp-elitebook-840-14-inch-g9-notebook-pc/2101000805.

 

Once the updates have been completed and the issue persists, please collect a discovery log from the affected devices and the EMA logs


Finally, if possible please confirm who is the certificate vendor, if the cert is sha 256 or sha 1


Looking forward to your updates.

 

Best regards,

Sergio S.

Intel Customer Support Technician



0 Kudos
FFern4
Novice
2,177 Views

HI

 

After doing more testing, it doesn't seem like the issue is related to Intel EMA. The origin of the problem is probably in the PC's

Find attached summary of behavior in different situations

  • When the PC is powered on, the CIRA tunnel is established without any problems: WiFi and LAN (if available)
  • When the PC is off and powered on, the CIRA tunnel is established through the LAN connection without any problems
  • When the operating system is shut down with the PC power supply connected, the CIRA tunnel is established through the WiFi interface.

In this case, If the power supply is disconnected and reconnected, the CIRA tunnel is no longer established through the WiFi interface, (until Windows is powered on again)

  • If when rebooting the computer, the option "Start Intel CIRA" is selected through the BIOS, the PC connects to the MPS using the WiFi connection (with the power supply connected or not)
  • However, if the PC is turned off and on again (not reboot), using again the option "Start Intel CIRA", the connection to the MPS is not established
  • Start Intel CIRA BIOS option always works if LAN interface is used instead of WiFi

 

I think the problem is related to how the BIOS and/or AMT handle the WiFi interface once the power supply is disconnected and reconnected, and the OS is off. In other scenarios, the CIRA tunnel works without problems using the WiFi interface.

If PC is rebooted, the WiFi interface keeps working with AMT, but if PC is powered off, the WiFi interface stops working with AMT until OS is booted

 

Regards

 

Fernando

0 Kudos
SergioS_Intel
Moderator
2,171 Views

Hello FFern4,


We appreciate your detailed response.


Based on the information provided: "if PC is rebooted, the WiFi interface keeps working with AMT, but if PC is powered off, the WiFi interface stops working with AMT until OS is booted" 


It seems that indeed the problem might be how the system BIOS handles the WiFi interface once the power supply is disconnected and reconnected. For that we do recommend contacting the system manufacturer for more information and check for BIOS/driver updates.



Best regards,

Sergio S.

Intel Customer Support Technician



0 Kudos
SergioS_Intel
Moderator
2,138 Views

Hello FFern4,

 

We are following this thread and would like to know if you need further assistance or if we can close it.

 

 

Best regards,

Sergio S.

Intel Customer Support Technician

 

0 Kudos
FFern4
Novice
2,130 Views

Hi

 

I have a case open with HP. I would like to have this thread open until I receive an answer from HP. I hope it will be soon

 

Regards

 

Fernando

0 Kudos
SergioS_Intel
Moderator
2,117 Views

Hello FFern4,

 

We will be looking forward to your updates. 

 

Best regards,

Sergio S.

Intel Customer Support Technician


0 Kudos
SergioS_Intel
Moderator
1,980 Views

Hello FFern4,

 

We are following your thread and would like to know if you have received any updates from HP support.

 

Best regards,

Sergio S.

Intel Customer Support Technician


0 Kudos
FFern4
Novice
1,959 Views

Hi

 

The case with HP is still open. They have requested me some additional information and some tests, including debug information, diagnostics, etc

 

There is not an answer/solution yet from HP

 

As soon I have, I will let you know

 

Regards

 

Fernando

0 Kudos
SergioS_Intel
Moderator
1,879 Views

Hello FFern4,

 

We are following your thread and would like to know if you have received any updates from the HP support team in regards you issue.

 

Best regards,

Sergio S.

Intel Customer Support Technician


0 Kudos
FFern4
Novice
1,813 Views

Hi

 

HP is still working on the problem. As far as I know, HP has contacted Intel to troubleshoot the issue

 

When I have news, I will let you know.

 

Regards

 

Fernando

0 Kudos
SergioS_Intel
Moderator
1,545 Views

Hello FFern4,

 

We are following your thread and would like to know if you have received any updates or if you need more assistance from us.

 

Best regards,

Sergio S.

Intel Customer Support Technician


0 Kudos
FFern4
Novice
1,520 Views

Hi

 

HP is still working on it. No fix found yet

 

Regards

0 Kudos
SergioS_Intel
Moderator
1,493 Views

Hello FFern4,

 

Thank you for the updates, we will keep the thread open and will follow up with you accordingly.

 

Best regards,

Sergio S.

Intel Customer Support Technician

 

0 Kudos
SergioS_Intel
Moderator
1,443 Views

Hello FFern4,

 

We are following your thread and would like to know if you have received any updates from the HP support team regarding your issue.

 

Best regards,

Sergio S.

Intel Customer Support Technician


0 Kudos
FFern4
Novice
1,421 Views

Hi

Still working with HP. The root source of the problem has been not found yet

Regards

Fernando

0 Kudos
SergioS_Intel
Moderator
1,381 Views

Hello FFern4,


At this point, since the issue is related to Hewlett Packard we will close this thread. We have discussed this with our manager and he is supportive of that direction moving forward.


Best regards,

Sergio S.

Intel Customer Support Technician


0 Kudos
Reply