Intel vPro® Platform
Intel Manageability Forum (Intel® EMA, AMT, SCS & Manageability Commander)
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

DN2820 Setup


I have purchased 3 DN2820FYKH NUC 1 of which was DOA of the other 2 they are proving hard to configure and use. On one I installed Mint 17.1, then lubuntu, then kodibuntu and gave up none of these could access the Toshiba MQ01abd100 1TB AF512e HDD so I bought a copy of Windows 8,1 x64 and Windows 7 SP1 x64. On the replacement for the DOA unit I loaded win 8.1 with no problems,Icould access HDD from windows. I wanted to know if the other OSes I listed would work, I tried kodibuntu and again could not access The hdd from the OS, reformatted with Gparted to NTFS and tried Windows 7 and got BSOD with error BIOS not fully ACPI compliant. I received this error on both of the functioning units, one with BIOS rev 0034 the other with rev 0048 The BIOS settings I used are:

  1. Press F2 when prompted during boot to enter BIOS Setup.
  2. Press F9 to set all BIOS options to default values.
  3. Select Advanced.
    1. On the Devices and Peripherals > SATA menu,Chipset SATA Mode is set to AHCI.
    2. On the Boot > Boot Priority menu, in the Legacy Boot Priority pane, Legacy Boot is enabled (checked).
    3. On the Boot > Boot Configuration menu, in the UEFI Boot pane, OS Selection is set toWindows 7.
  4. Press F10 to save and exit BIOS Setup.

Proceed with the installation of the operating system.

which I got from the Intel Downloadcenter. If you have installed win 7 on this model NUC please post your BIOS rev number and settings.

0 Kudos
2 Replies

Well here I am replying to my own post to install Windows do not follow the instructions from the Download Center, instead in step 3. a set SATA mode to IDE This worked for me.


Thanks for the follow up! Helped me out.