Intel vPro® Platform
Intel Manageability Forum for Intel® EMA, AMT, SCS & Manageability Commander
2860 Discussions

Enable TLS communication

watamaru2000
Beginner
1,316 Views

Please tell me how to enable TLS communication on a PC equipped with AMT Ver8.0.
(I couldn't find instructions on how to enable TLS communication in the PC manual.)
From a web search, I discovered that it might be possible to achieve this using a tool called MeshCommander, but I was unable to download the tool.
The website for MeshCommander is https://www.meshcommander.com/meshcommander.
By the way, I haven't tried it with other AMT versions either.

0 Kudos
1 Solution
MIGUEL_C_Intel
Moderator
1,300 Views

Hello, watamaru2000,


I hope this post finds you well.


Intel AMT 12 started supporting TLS version 1.2 and TLS version 1.0 was removed; TLS comes enabled by default.  A new client type has been created for TLS sessions, which uses a cipher suite with a block size of 256.  The latest remote management tool called Intel® Endpoint Management Assistant (EMA) requires endpoints with AMT version 11.8.79 or higher (the latest version is 16). https://www.intel.com/content/www/us/en/download/19449/intel-endpoint-management-assistant-intel-ema.html


AMT version 8 supports TLS1.1 and it is enabled by default.


Mesh Commander is a third-party open-source tool. I noted the tool was removed; it is not possible to download.


Intel still has Intel® Manageability Commander; this tool will allow remote accessing; however, the latest systems with AMT versions 15, 16, and higher are not compatible.  Please read the software description and guides included in the zip file.

https://www.intel.com/content/www/us/en/download/18796/intel-manageability-commander.html


Regards,

Miguel C.

Intel Customer Support Technician


View solution in original post

0 Kudos
4 Replies
MIGUEL_C_Intel
Moderator
1,301 Views

Hello, watamaru2000,


I hope this post finds you well.


Intel AMT 12 started supporting TLS version 1.2 and TLS version 1.0 was removed; TLS comes enabled by default.  A new client type has been created for TLS sessions, which uses a cipher suite with a block size of 256.  The latest remote management tool called Intel® Endpoint Management Assistant (EMA) requires endpoints with AMT version 11.8.79 or higher (the latest version is 16). https://www.intel.com/content/www/us/en/download/19449/intel-endpoint-management-assistant-intel-ema.html


AMT version 8 supports TLS1.1 and it is enabled by default.


Mesh Commander is a third-party open-source tool. I noted the tool was removed; it is not possible to download.


Intel still has Intel® Manageability Commander; this tool will allow remote accessing; however, the latest systems with AMT versions 15, 16, and higher are not compatible.  Please read the software description and guides included in the zip file.

https://www.intel.com/content/www/us/en/download/18796/intel-manageability-commander.html


Regards,

Miguel C.

Intel Customer Support Technician


0 Kudos
MIGUEL_C_Intel
Moderator
1,241 Views

Hello, watamaru2000,


I am following up on your post.  If further assistance is necessary, do not hesitate to reply.


Regards,

Miguel C.

Intel Customer Support Technician


0 Kudos
watamaru2000
Beginner
1,232 Views

Hello, Miguel,
Thank you so much for your help.
Your answer was very informative and solved my issue completely.

0 Kudos
MIGUEL_C_Intel
Moderator
1,200 Views

Hello, watamaru2000,


You are welcome. Do not hesitate to reply if anything else is necessary.


Regards,

Miguel C.

Intel Customer Support Technician


0 Kudos
Reply