Intel vPro® Platform
Intel Manageability Forum (Intel® EMA, AMT, SCS & Manageability Commander)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
2617 Discussions

Missing registry key for PKI provisoning

SWood7
Novice
1,931 Views

I'm getting a

"Missing registry key for PKI provisioning, make sure at least one certificate is selected for PKI provisioning"

Error in my SCS log. I've adden my own CA keys to my single profile. Could this be because I don't have matching certs on the actual PC itself?

0 Kudos
2 Replies
William_Y_Intel
Employee
277 Views

One thought I had to your particular problem: Did you run the loadcert utility that installs with SCS? You will find information about this utility on page 60 of SCS User Install Guide. You run this utility and select either the Verisgin Cert or Internal Cert you may have setup for Remote Configuration.

Steps from the User Guide:

Invoke the loadcert utility, located at <install_root>:\Program files\Intel\AMTConfServer\Tools. Double-click on loadcert.exe. Select the certificate that was just imported. The utility will report any problems in the certificates that it detects that would prevent using it as a Remote Configuration certificate.

SWood7
Novice
278 Views

You know I don't think I have. I believe when I read that you needed to contact once of the vendors whose root cert hashes are in the AMT firmware, I passed the section up. We have an internal CA but it appeared that you needed one of the vendor's hashes that are in the firmware.

Went ahead and ran the loadcert.exe and selecte the machine cert that I had created earlier and it appeared to load without any squawks. I restarted the demo machine and now I have a new message in the log! Something different. Now it says

No rows found in get Configuration Parameters.

Well, OK, I'll manually enter the UUID and see how that goes!

Reply