Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MPala11
New Contributor II
1,636 Views

SOL not redirecting text console data

Hi,

I have AMT system booted to DOS mode(Command prompt - text data only). AMT version is 7.0.

Now using Intel commander tool connected SOL. use Remote Control -> click Take control and connected to SOL mode

It's showing blank screen only. Actually AMT system has dos command prompt

Since it's a text screen it should redirected, but not redirected text data

Anyone explain about this?

If I use remote reboot option in Intel commander tool, AMT system restarts

and able to see post messages, text data in SOL. So do we need to reset

system to see text console data like DOS OS.

Similar to this AMT system is in BIOS screen and connected to SOL through commander tool, BIOS screen is not shown in Intel commander tool

Thanks,

Mani

0 Kudos
3 Replies
Joseph_O_Intel
Employee
44 Views

In order for a SOL session to get established, it requires a system reset. SOL does not act like a KVM session.

Please note AMT Commander is End of Life tool, please download the new tool located at:

http://opentools.homeip.net/open-manageability http://opentools.homeip.net/open-manageability

MPala11
New Contributor II
44 Views

Hi,

I understood that , sol options were available in BIOS. We need to set , reset the system for this setting to take effect.

From this Link, I understand the SOL operation

=====================================

http://software.intel.com/en-us/blogs/2010/01/10/my-amt-experience-2-intel-amt-sol-development-exper... My AMT Experience 2: Intel® AMT SOL Development Experience | Intel® Developer Zone

We shall set OemParametersType to 1 (UseSOL) in the remote boot parameter when remotely configuring client BIOS using Intel® AMT SOL. Only in this way can Intel® AMT BIOS boot in SOL mode and simultaneously export output data to the local display and SOL serial port, when both local and remote interfaces and operations are the same. Will SOL features be unavailable if we do not specify the parameter when we reboot the client? No. The only effect of booting without UseSOL parameter is that the BIOS output will not be exported to the SOL serial port.

====================================================

 

This usesol setting is valid till next boot. But If i issue reset from webui(http://ipaddress:16992/ http://ipaddress:16992), AMT machine get resetted, but usesol setting is true(checked by enumerating AMTBootSettingData class). Is this expected behaviour. This usesol propert remains true even when we enter BIOS and change some values and exit

If I do power off from webui, usesol setting is reset back to false.

 

Thanks,

Mani

Joseph_O_Intel
Employee
44 Views

Yes, you are correct

 

Reply