Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
960 Views

Unable to make vPro Powershell work

At my company the Windows build team is required to disable some AMT settings such as IDER. Its my job to audit their work which can be tedious so I would like to write a Powershell script to do the work for me. I guess my first question is, do I need to use the vPro Powershell module or should I be trying to do this with some other cmdlet that is built-in to Powershell? So far I have taken the approach that the vPro Powershell module is the way to go but I am open to other suggestions.

Specs: Windows 7 Enterprise SP1

32bit

Powershell 2.0

Intel Management Engine BIOS Extension v6.0.3.0019 / Intel ME v6.0.40.1215

I am launching Powershell as an administrator locally on the machine that I want to access AMT settings.

Import-Module IntelvPro

Write-AmtCredential

( I'm not exactly sure what password to enter here. When I boot this HP EliteBook 8440p I have to press CTRL+P to get into MEBx/ME. At this point I am prompted for a password but not a username. I made the assumption that Write-AmtCredential wants this password [1]. And I think I read somewhere that a default username of 'admin' will be passed in automatically??)

$AmtPassword = Get-AmtCredential

Get-AMTFirmwareVersion -computername:laptop2 -credential $AmtPassword

 

Output:

ComputerName Property Value

--------------------- ----------- --------

blw7027 Error Cannot Connect

I have also tried

Get-AMTFirmwareVersion -computername:laptop2

without the credentials option to see if it would accept my administrator credentials. Have also tried using -computername with the FQDN.

[1] I verified that I am entering the correct password by booting the laptop and entering into MEBx/ME.

What am I missing?

0 Kudos
0 Replies
Reply