Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12475 Discussions

Kernel 2.6.x and SL811HS Problem

Altera_Forum
Honored Contributor II
887 Views

Hello All: 

 

We are using an SL811HS USB host in our system, running the Microtronix 2.6.4 kernel and are having the following issue. 

 

I am compiling in the SL811-HCD driver and, when booting the kernel, the driver loads, prints a single line of introductory header information to the console and then, apparently, quits. 

 

I find that the driver, after printing the header information from the function sl811h_init(void), does not chip-select the SL811 and so I stuck a  

printk("STARTING PROBE") statement into the function sl811h_probe(struct device *dev) just to see if if's getting that far and... it isn't.  

 

Getting back into sl811h_init(void), I check the return value from  

driver_register(&sl811h_driver)  

and it is 0 but this is as far as I have gotten so far. 

 

The SL811HS driver in the previous version of the kernel seemed to work well although I never really got the chance to hammer it. I don't believe that this problem exists in the SL811-HCD driver file itself but, of course, I could always be wrong!! 

 

In searching through this Forum, I found another post which describes what I believe to be the same problem but... no responses thus far. 

 

 

Any ideas??? 

 

Thanks in Advance! 

 

Nick
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
87 Views

It's been long time since you were working on that driver, But right now Im working on that driver as well and I got the same problem. Im wondering if you solved that problem and If you could tell me some information about that driver. Thanks a lot. 

 

 

 

Fabian Salas
Reply