Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12620 Discussions

Arria10 U-boot make error using Ubuntu 14.04

Honored Contributor II

I am attempting to compile Uboot and the Uboot DTS for the Arria 10 SoC dev kit per the instructions on the GSRD on I have successfully generated the BSP using the BSP-editor, and upon running 'make' I get this error in the terminal (running from Embedded command shell from my uboot_bsp directory): 



/bin/sh: 1: arm-altera-eabi-gcc: not found 

dirname: missing operand 

try 'dirname --help' for more information. 

scripts/kconfig/conf --silentoldconfig kconfig 

chk include/config.h 

gen include/ 

/bin/sh: 1: arm-altera-eabi-gcc: not found 

/localcad/sf/arriax/a10_soc_1588/a10_soc_devkit_ghrd/software/uboot_bsp/uboot-socfpga/scripts/makefile.autoconf:64: recipe for target 'include/' failed 

make[3]: *** [include/] error 1 

/localcad/sf/arriax/a10_soc_1588/a10_soc_devkit_ghrd/software/uboot_bsp/uboot-socfpga/makefile:464: recipe for target 'silentoldconfig' failed 

make[2]: *** [silentoldconfig] error 1 

make[1]: *** no rule to make target 'include/config/auto.conf', needed by 'include/config/uboot.release'. stop. 

make[1]: leaving directory '/localcad/sf/arriax/a10_soc_1588/a10_soc_devkit_ghrd/software/uboot_bsp/uboot-socfpga' 

makefile:216: recipe for target 'uboot-socfpga/u-boot.bin' failed 

make: *** [uboot-socfpga/u-boot.bin] error 2 


Any ideas on what could be the issue :confused: 


0 Kudos
2 Replies
Honored Contributor II

Just in case it helps someone else - I have fixed the issue.  


For the sake of still making progress, yesterday I had moved on in the GSRD instructions to building the Linux device tree and Linux itself. The instructions for building Linux included adding/installing some libraries. And it seemingly has fixed my issue and it now builds u-boot with no errors. I'm not certain which one fixed it, but here are the commands, one of which would have fixed it: 


sudo apt-get update 


sudo apt-get upgrade 


sudo apt-get install phablet-tools sed wget cvs subversion git-core coreutils unzip texi2html texinfo libsdl1.2-dev docbook-utils gawk python-pysqlite2 diffstat help2man make gcc build-essential g++ desktop-file-utils chrpath libgl1-mesa-dev libglu1-mesa-dev mercurial autoconf automake groff libtool xterm lib32z1 


sudo apt-get install ia32-libs lib32stdc++6 


sudo ln -sf bash /bin/sh 


... So I'm not sure which would have fixed it - possibly the lib32stdc++6 ?
0 Kudos



I am having same error , but it is not getting resolved by including above packages, Also while entering : sudo apt-get install ia32-libs lib32stdc++6 , error occurs.


Package ia32-libs is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However the following packages replace it:

 lib32z1 lib32ncurses5 lib32bz2-1.0


E: Package 'ia32-libs' has no installation candidate


Which tar.gz file you have downloaded for the uboot source code and have you used any build command before make?

I am following for uboot binary.

can you provide any solution.



0 Kudos