Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12622 Discussions

BootROM output over miniUSB port

Honored Contributor II

i've tried both MSEL 01010 and 00000 settings, and connected to the console with "screen /dev/ttyUSB0 115200" and im trying to get u-boot-socfpga to boot.  


the u-boot is compiled to output console to /dev/ttyS0 with baudrate @ 115200, but all i get is a black screen. 


the sdcard is partitioned with mbr table, and first partition is fat32 800mb second is a ext3 partition 1GB and third is the raw 0xa2 partition 1MB large. (which is more then enough for 4x 64kb preloader images and the full u-boot image ~300-400kb. 


but it seems that the HPS BootROM doesnt find the preloader on the sdcard.  

otherwise i would have some kind of text on the USB serial cable.. 


is it possible to see the BootROM process in some way? usually on devcards boot0 and boot1 (before uboot is loaded) already outputs console output so you see what happens. 


i know the HPS works, i've run the precompiled sdcard image terasic got available. but now i need to work out how to get embedded linux rolling on this HPS.. 




another thing that might be intresting.. the TXD/RXD leds only time they blink is when miniUSB is connected, both flash 3 times rapid. 



tried with alteras prebuilt u-boot.img (as full u-boot ) and and prebuilt "preloader-mkpimage.bin" as preloader instead of my own built u-boot, but with same result.. not a single char displays over the miniUSB.. 



tried now with the sdcard image that is included in SoCEDS 13.1 but that one doesnt boot ether.. the one i used last time (about 6months ago) i think was one of the images from terasic, so i'll try those again.. 


edit again... 


something seems to be different between terasic's image and the included sd_card_linux_boot_image.tar.gz (its a img file inside the tar so i havnt written the compressed file to the sdcard.. guess someone will ask that..) that is included with SoCEDS.. 


cause the SoCEDS one doesnt boot on my DE1-SoC.. 


root@socfpga:~# U-Boot SPL 2013.01.01 (Nov 04 2013 - 19:51:38) BOARD : Altera SOCFPGA Cyclone V Board SDRAM: Initializing MMR registers SDRAM: Calibrating PHY SEQ.C: Preparing to start memory calibration SEQ.C: CALIBRATION PASSED ALTERA DWMMC: 0 U-Boot 2013.01.01 (Oct 24 2013 - 17:40:22) CPU : Altera SOCFPGA Platform BOARD : Altera SOCFPGA Cyclone V Board DRAM: 1 GiB MMC: ALTERA DWMMC: 0 In: serial Out: serial Err: serial Net: mii0 Warning: failed to set MAC address Hit any key to stop autoboot: 5  


so the HPS seems to work.. guess i'll have to use u-boot binaries from that image, to get stuff rolling, but i would like to know why it doesnt work with u-boot-socfpga git repo from
0 Kudos
0 Replies