Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12618 Discussions

Issues linking library (.lib/.dll) in Nios II Software Tools for Ecplise

Honored Contributor II

Hello all, 


I am wondering if anyone out there might be able to help me link a library (Iddk2000.lib/.dll) to my project in Eclipse IDE for C/C++ Developers Version: Indigo Service Release 2 using the MinGW Nios II GCC4 toolchain. 


I have been struggling with this for awhile but cannot seem to get any results. Currently, I am including the path to the library and library name in "C/C++ General -> Paths and Symbols" and in "Nios II Application Properties -> Nios II Application Paths" which updates the makefile accordingly but causes error during compilation. The error I have been getting is "ld.exe: cannot find -lIddk2000". 


In various attempts to solve this I have tried both 32 bit and 64 bit versions of the library, I have tried local and external file locations and I have tried just linking the .lib, just linking the .dll and linking both. I am curious if anyone has experienced this before and if so how might I fix it? I will include pictures of my linker settings and of the compiler line causing error. 


Setting Library Path:  


Setting Library Name:  


Setting Application Paths:  


Compiler Argument / Error:
0 Kudos
0 Replies