Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++

JTAG connection failed



Problem description: JTAG connection failed, consistency, after every time, when stop the debugger on NIOS II hardware:

Problem messages: Here are the following error (Appendix 1- Error massage):   

Popup message:

‘Launching <project name> Nios II Hardware configuration’ has encountered a problem. Downloading ELF Process failed.

From the Console:

There are no JTAG cable available on your system which match the –cable option you provided (USB-Blaster on localhost (USB-1)).


  1. The only thing that can restore back the connection is reset to the computer (I’ve tried to close the Quartus and reopen it, disconnect and reconnect the JTAG cable, regenerate the Platform designer and burn the .sof and regenerate the eclipse project- the JTAG connection will not restore).
  2. The positive thing is that the problem is consistency- it will happen after every time in the following order:  

restart my computer→ Open Quartus (18.1) → burn .sof (only one time because I after the JTAG disconnected, it doesn’t help if I disconnect the power to the EVM)→ open Eclipse with the project→ compile → Run as Nios II hardware → successfully debag the project (break points…) → stop debugging →  change/ unchanged my C code → compile → Run as Nios II hardware → JTAG Error (as mentioned in the Problem message section) → reset computer → restart my computer→ repeating the process (it will be available now)…

  1. I’ve tried to increase the RAM CPU to maximum of 262144 and used the small C libraries (Appendix 3)- the JTAG connection keep disconnect will not restore.


This problem dramatically increases the overhead of the debugging process so I really need a solution for that.  

Thanks a lot,


0 Kudos
1 Reply

Can you check Ignore mismatched system ID.

0 Kudos