Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12602 Discussions

My problem is, that in the Run- and Debug-Configurations the "NiosII Hardware" Section is missing (under "Run As" / "Debug As"). Only the "Local C/C++ Application" can be selected.

FENGE1
Beginner
611 Views

Hi there,

 

I am using Quartus 11.1sp2_259, and i also installed 11.1 SP2 Patch 2.11 for Windows in order to be able to use the USB-Blaster. My operating System is Windows 10.

My problem is, that in the Run- and Debug-Configurations the "NiosII Hardware" Section is missing (under "Run As" / "Debug As"). Only the "Local C/C++ Application" can be selected.

 

After searching answers in the forum, I allready tried the following, but without success unfortuneately:

- Reinstalled the complete Quartus 11.1

- Running the NIOSII in compatibility mode for windows, and running it as an Administrator

- Checked if multiple USB-Blaster's are configured with "jtagconfig.exe" (only one was present)

- Generating a new "HelloWorld" project from scratch

 

Can you please advise me on what might be the problem with my configuration?

 

Thanks and best regards,

 

Florian Engeler

0 Kudos
2 Replies
FENGE1
Beginner
393 Views

I nevertheless finally resolved the issue by using the windows compatibility mode. For some reason this did not work when i did it manually, but when using the windows trouble-shooter, it worked fine:

https://www.laptopmag.com/articles/set-compatibility-mode-windows-10

0 Kudos
Ahmed_H_Intel1
Employee
393 Views

Great news, I happy you solved the issue. Please let me know if you need more support.

 

0 Kudos
Reply