Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12616 Discussions

Need help::: Error: Node instance "XXX" instantiates undefined entity "XXX"

Altera_Forum
Honored Contributor II
3,462 Views

Hi all, 

I am using nios processor to controll the userlogic(verilog) for my project.I have little experience with schematic entry. so I have created the symbol from the verilog code and I have connected both systems. 

When I try to compile my design I am getting this kind of errors. 

 

Error: Node instance "onchip_mem" instantiates undefined entity "processor18_onchip_mem" 

Error: Node instance "cpu18" instantiates undefined entity "processor18_cpu18" 

Error: Node instance "jtag_uart18" instantiates undefined entity "processor18_jtag_uart18" 

 

Those are just examples I am getting 64 errors(for each part I have used in processor ).Is there anyone having idea about this error. 

 

My final design should work exactly like as you see in the picture.
0 Kudos
5 Replies
Altera_Forum
Honored Contributor II
1,635 Views

Sorry for the previous post, 

 

I forgot to add .qip file to my project.But still I have a problem.If you see the schematic you will find a bidirectional bus (data_pio_external to port_0_io ).Is it proper way of connecting bidirectional nodes.Because I am getting some Error: Port "port_0_io[0]" does not exist in macrofunction "inst".
0 Kudos
Altera_Forum
Honored Contributor II
1,635 Views

You should only use bidirectional signals when connecting to i/o ports of the FPGA. Signals inside the FPGA can only go in one direction. I don't think Quartus can synthesize an internal bidirectional bus, it will probably stop with a multiple drivers error.

0 Kudos
Altera_Forum
Honored Contributor II
1,635 Views

 

--- Quote Start ---  

Sorry for the previous post, 

 

I forgot to add .qip file to my project.But still I have a problem.If you see the schematic you will find a bidirectional bus (data_pio_external to port_0_io ).Is it proper way of connecting bidirectional nodes.Because I am getting some Error: Port "port_0_io[0]" does not exist in macrofunction "inst". 

--- Quote End ---  

 

" i am facing same problem for compilation, but i can't understang what the .qip file is and how to add it to project. please help."
0 Kudos
Altera_Forum
Honored Contributor II
1,635 Views

Hi sarath  

were you able to solve your problem with this Error (12006): Node instance "xxxx" instantiates undefined entity "xxxx" ? If you did, could you please explain how did you manage it? 

 

Thanks
0 Kudos
Altera_Forum
Honored Contributor II
1,635 Views

This error means that you don't set you own library, yet. Go to assignments >> settings >> library (category field) >> add your library path, then apply it.

0 Kudos
Reply