Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12603 Discussions

New application creation failure in NIOS II - Quartus20.1

VinayGB
Novice
2,322 Views

I have installed Quartus 20.1 and followed instructions in n2sw_nii5v2gen2.pdf to install wsl2 and then Ubuntu and eclipse. 

In eclipse workspace, when I try to create new application and bsp from template, following error message pops up 

Failed to execute: wsl dos2unix create-this-bsp; ./create-this-bsp --cpu-name cpu_nios --no-make

Attached is the console prints when this error occurs.

Kindly support in creating new application and bsp in NIOS II - Quartus 20.1

I have tried all the solutions available in the community, like run as admin, changing between wsl1 and wsl2 and many more.

regards,

Vinay

 

0 Kudos
4 Replies
MViss4
Novice
2,312 Views

Note in 19.4 when opening an 'Nios II Command Shell (Quartus Prime Pro 19.4)' command shell and running 'nios2-bsp-create-settings' results in "nios2-bsp-create-settings: command not found".
However running 'nios2-bsp-create-settings.exe' (with .exe extension) does work. 
In the Makefile there is some logic for this:

UNAME = $(shell uname -r)
ifeq ($(findstring Microsoft,$(UNAME)),Microsoft)
WINDOWS_EXE = .exe
endif

Refer to https://community.intel.com/t5/Nios-II-Embedded-Design-Suite/Error-s0-Error-during-execution-of-quot-C-intelfpga-20-1-quartus/td-p/1191914 as the uname is case dependent and only works for WSL1. 

Probably your 'nios2-bsp-create-settings' is executed without '.exe' extension you can try to adapt the Makefile to use a hardcoded ".exe" extension

0 Kudos
Eliath_G_Intel
Employee
2,283 Views

Hi Vinay!

Thanks for reaching us.


I see that Mviss4 has already provided you a workaround,

I'd like to know if you have tried and if this solved your issue.

and please, share with me the OS you're using ( Windows or ubuntu) and also the Quartus version.


Regards,

-Eliath


0 Kudos
VinayGB
Novice
2,265 Views

I am using Quartus 20.1 in Windows 10 OS.

I have installed-uninstalled-reinstalled wsl and ubuntu multiple times, but to same result.

I have not tried the work-around provided, as it is confusing. How do I adapt a makefile, if the project itself is not getting created ?

Kindly provide proper procedure to follow for creating new projcet and building it.

Please donot leave tool debugging to the users.

Kindly provide step-by-step approach of new application creation, building and debug/run.

regards,

Vinay

PS : Due to project timelines, I am forced to revert back to Quartus version 14 where Nios SBT works without any issues. Debugging NIOS SBT is not my job domain(although I had spent many days making it work). I had tried installing Quartus 20.1 and building same project in two different computers and every time I am getting new errors.

0 Kudos
Mack
Beginner
2,205 Views

For me, I was able to fix this by editing nios2-bsp (in C:\intelFPGA_lite\20.1\nios2eds\sdk2\bin). There's a line that checks if you're running WSL:

uname=$(uname -r)
if [[ $uname =~ "Microsoft" ]]; then
_IS_WSL=1
windows_exe=.exe
fi

 

On line 37, it should be changed to:

if [[ $uname =~ "microsoft" ]]; then

 

This then causes the script to add .exe to the end of all the executables and a few other things that fixed it for me.

0 Kudos
Reply