Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
12583 Discussions

NiosII 9.1 Import Error: Makefile is not Software Build Tools compatible

Altera_Forum
Honored Contributor II
1,594 Views

Hi, 

I am a makefile novice. I just completed re-making our library makefile based on the nios2-lib-generate-makefile command we were previously using IDE generated commands that were no longer supported.  

 

It turned out that a lot of the variables provided by default were not used and also the public.mk did not contain anything, so I stripped them out to improve maintainability. My makefile compiles splendidly from the command line but when I try to import it into the Nios II 9.1 Eclipse GUI, I get an error saying Makefile is not Software Build Tools compatible.  

 

I looked in Software Developer's Handbook and read Section I and looked through Section 4 but didn't see any reference to what was required by the GUI to make the makefile compatible? It just encouraged you to utilize the autogenerated files as a basis and said you could write your own but said nothing about compatibility issues. I tried using the NiosII help search option but it caused the GUI to instantly quit? 

 

There are a lot of documents perhaps I just missed the one that explains a minimum set of requirements for importing into eclipse for debug.
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
337 Views

Add the following to your makefile. Also make sure it's called Makefile and not makefile. 

# -------------------------------------------------------------------------------# Following line needs to be included so the eclipse environment recognises# the project and imports it. Go figure. 

CREATE_ELF_DERIVED_FILES := 0 

 

 

 

From memory it also works with a# in front of CREATE 

go figure.  

Wasted a couple of hours of my life figuring this crap out.
0 Kudos
Altera_Forum
Honored Contributor II
337 Views

Bless you, import now works and it builds too.  

I never would have figured this out.  

 

Thanks!!!!! 

Jennifer
0 Kudos
Altera_Forum
Honored Contributor II
337 Views

Looks like you also have to set the CREATE_LINKER_MAP variable.

0 Kudos
Reply