Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++

QSPI boot problem


Hello, I am trying to boot a NIOS II processor simple design (Hello World) from an external QSPI flash(software application). I am using MAX 10 FPGA Development Kit. I tried all 3 external flash options from AN730: 4a,4b and 5. None of them seem to work. I tried the same design using 1a and 1b options (on-chip flash UFM) and it works. The external flash seems to work well: program/verify.

I think the problem arises when the NIOS II tries to boot. For some reason, it looks like NIOS II boots from the wrong location or the flash memory image is corrupt. I was following every step from AN730 document multiple times with no luck.

Any suggestions for what I do wrong?

Thank you for your help!

0 Kudos
1 Reply



Have you tested below example:


Are you facing the same issue when using above example?

0 Kudos