Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12603 Discussions

Running a Program from SDRAM instead of OCRAM

Honored Contributor II


I'm currently trying to run code I had previously run on the OCRAM onto the SDRAM.  

I was using the Bare Metal User Guide( to do this, but found that changing the scatter file and using the preloader didn't help. I have tried adjusting the settings in the bsp-editor when creating my preloader but haven't had any luck so far. I am using the DS-5 compiler. 


The error I'm given is like this, which according to the tutorial is appearing because there is no preloader: 


ERROR(CMD16-TAD274-NAL22): ! Failed to load "bare metal-hello-world-01.axf" ! Failed to write 4,896 bytes to address S:0x02000000 while writing block of 4,096 bytes to address S:0x02000000 ! General error on memory or register access. 


I am using this as my scatter file: 


SDRAM 0x02000000 0x02000000 ; 32M SDRAM { APP_CODE + 0 { * (+ RO , + RW , + ZI ) } ARM_LIB_STACKHEAP 0x03000000 EMPTY 0x0x01000000 ; Application heap and stack { } } 


I'd appreciate any direction anyone could provide, including messing with any other settings available for this.
0 Kudos
2 Replies
New Contributor I



I feel your pain! Just found your question while searching for "! General error on memory or register access." .... I have the same issue. I have the feeling that my preloader is not working correctly or is not being loaded by bootROM correctly for some reason ..... but I'm in the dark. Zero support from Alter/Intel........ the docs and examples are good - in perfect world when stuff just works... if they don't .... there's very little way to find out what'sup.




0 Kudos

Same problem I am facing, and I have tried by doing lots and lots of alterations but it doesn't work. The Intel Guys are non-responsive. This is just one example. There are few places where when one when get stucks, no one is there to answer/solve the query.

0 Kudos