Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12622 Discussions

niosII-ide not working in 12.0 (Linux)

Honored Contributor II



I have a problem with the newest release of QuartusII/NiosII-IDE (12.0). I run Ubuntu 12.04 and I've gotten both Quartus and the Usbblaster programmer working, but I can't seem to get the nios2-ide (eclipse) to work. 


The entire situation is very strange. Launching the NIOSII software link from the menu in Quartus does absolutely nothing, so I tried launching it manually from a terminal. 


I run: 


$ altera/12.0/nios2eds/ ------------------------------------------------ Altera Nios2 Command Shell Version 12.0, Build 178 ------------------------------------------------ $ nios2-ide $  


...and the result from the second command (to start the IDE) is... nothing. No error message, no popup, nothing. It just sits there for a few seconds, then return to the prompt. Some further digging led to the (kind of) root of the problem: eclipse. 


$ altera/12.0/nios2eds/bin/eclipse_nios2/eclipse  


The above command has the same behavior. It won't boot eclipse. 


I've verified the following: 


* The nios2-ide was, until very recently, working on linux (I have a previous installation, just a week old and using the 11.1 edition of QuartusII, up and running on a different computer). 


* I can run eclipse on my system. I downloaded Eclipse classic Indigo (Version: 3.7.2, Build id: M20120208-0800), and it works without any problems. 


So, is there a problem with the eclipse package bundled with QuartusII/NiosII-ide 12.0? Has anyone else seen this problem? Is the bug present on Windows too?
0 Kudos
1 Reply
Honored Contributor II

I made some progress on this and now have the system running... it is rather ugly, but it works. 


Turns out I was trying to run the wrong executable, when I tried to run: 


$ altera/12.0/nios2eds/bin/eclipse/nios2-ide  


instead, I got some more helpful error messages. Since I'm running a 64-bit system, I was missing some 32-bit gtk libraries. 


I installed (64-bit Ubuntu 12.04): 


$ sudo apt-get install libgtk2.0-0:i386 libxtst6:i386  


Running nios2-ide still raised a TON of errors, but at least the program started, and is functioning properly (I can compile code and download to my DE2-115). 


...still, this should work out of the box. Alteras linux releases are not exactly optimal...
0 Kudos