Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12595 Discussions

"Description Resource Path Location Type fatal error: altera_msgdma.h: No such file or directory". This is the error I'm getting if I run Nios II Simple Socket Server (16.0) in the Intel Quartus version 17.1


17.1_problems.png16.0_problems.pngI have downloaded the .par file from the link ( and followed the steps to create software project as given in the pdf .

The quartus version that I've used is 17.1.

If I use Quartus version 16.0, I am getting the different errors related to "DESCRIPTOR_MEMORY_BASE" undeclared here (not in a function).

I am attaching the screenshots of the errors related to both versions i.e. 16.0 and 17.1.


I have even tried the fixes that are mentioned in

wherein I have used eth_std_main_system.qsys as the QSYS_TOP mentioned in that link. But it couldn't reslove.


Kindly help me out

0 Kudos
2 Replies


I am trying to implement triple speed ethernet in nios processor using modular scatter gather dma (msgdma) controller. I have build the qsys. For memory i have used ram. I have called 2 msgdma one for receiving in streaming to memory mode and one for transmitting in memory to streaming mode. I have done the interconnections in qsys platform and generated the HDL successfully. The sopcinfo file is also generated. Using this sopcinfo file i tried to generate the bsp. The bsp generates but when i try to build the bsp project in eclipse the build fails. It says that " fatal error. altera_msgdma.h. No such file exists."

I am using Quartus 18.1. I cannot downgrade to lower version as i have progressed a lot in 18.1 and now cannot migrate to a lower version because of dependency issues.

Actually this file is missing in alt_avalon_tse.h. The altera_msgdma.h exists in the installation folder of quartus 18.1 in c drive. But some how when i try to build the bsp it doesn't pick that file and throws the above mentioned error. I have tried to manually move altera_msgdma.h and altera_msgdma.c file into the incude and source file of the driver folder of the project file. After doing this the bsp builds, but the actual project build fails.

I am not using linux

Kindly guide




0 Kudos