Community
cancel
Showing results for 
Search instead for 
Did you mean: 
andre_i_
Beginner
303 Views

Entry Point Not Found

 

Hi
So I was trying to do this code from
link : https://www.fixstars.com/en/opencl/book/OpenCLProgrammingBook/first-opencl-program/


and I encounter some problem

Capture.PNG

Output log 

'TrainOpenCL.exe' (Win32): Loaded 'C:\Users\Andre Ivan\Documents\Visual Studio 2013\Projects\TrainOpenCL\x64\Debug\TrainOpenCL.exe'. Symbols loaded.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\ntdll.dll'. Symbols loaded.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\kernel32.dll'. Symbols loaded.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\KernelBase.dll'. Symbols loaded.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\OpenCL.dll'. Cannot find or open the PDB file.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\msvcr120d.dll'. Symbols loaded.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\advapi32.dll'. Symbols loaded.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\msvcrt.dll'. Symbols loaded.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\sechost.dll'. Symbols loaded.
'TrainOpenCL.exe' (Win32): Loaded 'C:\Windows\System32\rpcrt4.dll'. Symbols loaded.
The thread 0x3938 has exited with code 0 (0x0).
The thread 0x372c has exited with code 0 (0x0).
First-chance exception at 0x00007FFC00CB4820 (ntdll.dll) in TrainOpenCL.exe: 0xC0000139: Entry Point Not Found.
The thread 0x3768 has exited with code -1073741511 (0xc0000139).
The program '[14172] TrainOpenCL.exe' has exited with code -1073741511 (0xc0000139) 'Entry Point Not Found'.

I suspect something is wrong with my OpenCL.dll which cause error on clCreateCommandQueueWithProperties function. I am also confused even when I change the function into clCreateCommandQueue the same error also come out.


Thank you.

 

0 Kudos
1 Reply
Jeffrey_M_Intel1
Employee
303 Views

You may be seeing this due to something not quite right in how your program is linking the OpenCL libraries, or there may be an issue with the path to the DLLs needed when run. 

I was able to get this example to run by starting with a new "Empty OpenCL Project" and pasting in the hello.c and hello.cl code.  You can also start with a CodeBuilder Wizard project.  Are you able to get one of these to run on your system?  If yes, then your issue is probably project setup.  If no, does reinstall help? 

CodeBuilderNewProj_0.png

 

Reply