OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

The new Intel® SDK for OpenCL™ Applications 2014 is Here!

ARNON_P_Intel
Employee
510 Views

Dear OpenCL developers,

The new Intel SDK for OpenCL Applications 2014 introduces a unified software development environment for OpenCL API with new debugging capabilities.

New production features:

  • Unified SDK with support for Intel® CPUs, Intel Xeon Phi coprocessors, and Intel® Graphics
  • Extended support for Intel Atom processors with Intel® HD Graphics and with PowerVR* G6400
  • Remote development for OpenCL™ on Android*
  • API-level debugging
  • New OpenCL runtime (version 14.1) for Intel CPU and Intel Xeon Phi

New preview features:

  • OpenCL kernel step-by-step debugging on Intel Graphics
  • SPIR 1.2 code generation and consumption
  • Kernel code advising for optimized code

This new version combines all features previously available with the 2014 Beta, SDK XE 2013, and SDK 2013 products. All developers are recommended to upgrade to this new version and update the relevant drivers and runtimes.

Learn more and download today at: https://software.intel.com/en-us/vcsource/tools/opencl

Regards,

Arnon Peleg

0 Kudos
13 Replies
Uri_L_Intel
Employee
510 Views

Hello everyone,

We’ve found a critical issue in the OpenCL runtime installation package for Intel Xeon Phi devices on Linux* operating systems.

We’re currently working to provide a fixed package which will be released soon

 

We’re truly sorry for the incontinence and will do our best to upload the fixed package as soon as possible.

 

Thanks,

Uri

Raghupathi_M_Intel
510 Views

Hi All,

The issue has been fixed and you can download the latest package. Again sorry for the inconvenience.

Thanks,
Raghu

 

Joseph_P_
Beginner
510 Views
It only wants to give me a .exe download. This doesn't work quite as well as one might wish on Linux. Is the OS detection horked?
ABoxe
Beginner
510 Views

Yes, only an exe is available, and the file has 2013 in the name, rather than 2014.

Andrey_Vladimirov
New Contributor III
510 Views

+1. Tried Firefox and Opera in CentOS 6.5. The .exe file starts downloading automatically, without giving me any other download options.

Andrej_M_
Beginner
510 Views

Hello,

is this thread still alive? As nobody answered the SDK 2014 download problems: there is NO "2014" version available under the everywhere published link. The provided .exe is Windows only and named "2013_r2" - and it's really the old version not only wrongly named, as after installation there is NO Visual Studio 2013 support, only the 2012 and 2010 are integrated :-(.

Please, provide us with the new version as w/out being able to integrate it to the VS2013 there is no use in the whole deprecated SDK.

Thank you,

Andrej

alexjc
Beginner
510 Views

I noticed all the same problems here too.  Also, the registration form is useless since you can fill it with almost random characters... :-)

Why not just provide a link?  I will download this on multiple machines and don't want to have to fill in the same form over and over!

Please fix, it's been a month since the supposed release.

ARNON_P_Intel
Employee
510 Views

Hi everybody,

We truly sorry for the confusion on the wrong link in our product page. We will fix it ASAP.

At the meantime, please register and download directly from: https://makebettercode.com/opencl/

Arnon

ARNON_P_Intel
Employee
510 Views

alexjc wrote:

Why not just provide a link?  I will download this on multiple machines and don't want to have to fill in the same form over and over!

Alex,

After registration, you can copy and save the full URL and reuse it again on other machines.

Regards,

Arnon

Andrej_M_
Beginner
510 Views

Wow, much appreciated, thank you :-D!

Cheers,
Andrej

Joseph_P_
Beginner
510 Views
The link is working for me now as well. Thank you very much!
Antol_R_
Beginner
510 Views

Currently experiencing major problems with downloading:

http://registrationcenter.intel.com/irc_nas/4180/intel_sdk_for_ocl_applications_2014_x64_setup.msi

and

http://registrationcenter.intel.com/irc_nas/4180/opencl_runtime_14.1_x64_setup.msi

While having a download speed of 13.7 Mbit/s at speedtest.net, the Intel downloads seem to stop or continue at nearly 0kb/s rate.

Sometimes getting 404 errors when trying to reconnect to the download source.

ARNON_P_Intel
Employee
510 Views

Hi,

Working fine in my system. Looks like a temporary slowdown in the download server. Please check again tomorrow (Monday) and let's us know if you still experience problems.

Regrads,

Arnon

Reply