OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU.
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1720 Discussions

after upgrading graphics drivers, cant find platform ID anymore


I've just started working with openCL as a part of small research if it could significantly increase execution of other projects. I installed Microsoft's VS 2008 along with Intel's openCL SDK 1.5, then run couple of examples, however only CPU was recognised as valid openCL device. So I've upgraded gpu drives in hope it will do the trick.

However that worsen the situation, now whatever test project I try to run it would not be able to get platformID. I tried to uninstall everything along with cleaning the registry of openCL entries, however I problem still occures.

Does anyone seen this problem before? Is there any solution to it?

(Clean install is rather inconvinient and might be used as last resort)
0 Kudos
3 Replies
hi Gottimw,
I had a big reply and I accidentally closed the tab. Shoot!
Anyway here is the most of what I had to say.
A few Questions:
Are you trying to do CPU and GPU OpenCL calculations?
What GPU do you have?
What GPU driver version did you install? This is actually important as AMD and NVidia install their OpenCL runtime with the default download of their drivers. They may be interfering but I don't think that is likely as they are much much better about this than they used to be.
Does you inital call to clgetplatformids tell you there are 0 platforms or is the issue with the second call when you try to actually get the platform ids?
You might try doing a complete uninstall of your graphics drivers and then get the latest version, then uninstall the intel sdk, then install the latest graphics drivers, then install intel OpenCL SDK.
Also make sure your environment variables are setup correctly.INTELOCLSDKROOT needs to point to the root of your install directory.
Until you get it figured out (please forgive me Intel) you can install the AMD OpenCL runtime to start working with your CPU as AMDs drivers work with any CPU with SSE3 or greater. I don't recommend that as a permanant fix as the Intel drivers are much much better for Intel hardware but I wanted to give you an option so you aren't stuck while you get this figured out. We run the amd drivers and the intell ones and can switch between them without issue so you should be able to get moving with these while you troubleshoot the Intel SDK.
0 Kudos
At this stage I would like to be able to run some code just on CPU. All env vars are set and are pointing to approprieate directories.

clgetplatformids() returns zero platforms found.

In regards to GPU driver I tried to uninstall and prone everything that has to do with openCL, env vars and registry entries, uninstalled gpu driver so its default VGA sys driver. and just instal SDK 1.5 yet this doesn't work either.

But i think I'll just wipe the system and start from the begining (unless you have an idea what could be causing it)
0 Kudos


Please try to completely remove the Intel OpenCL CPU runtime package and the SDK package from your system and install the SDK again.

To uninstall the SDK use the Microsoft Windows* Control Panel (search for Intel OpenCL SDK record in the Program and Features list). or select Start > All Programs > Intel OpenCL SDK > Uninstall Intel OpenCL SDK to uninstall Intel OpenCL SDK 1.5.

To uninstall the runtime package use the Microsoft Windows* Control Panel (search for OpenCL 1.1 support for Intel Core processor family record in the Program and Features list). Please note that Youll need to reboot your system after the runtime package uninstall finished to complete the un-installation process.

Afterthe uninstall completed, please delete the OpenCL ICD from your system (the installer doesnt remove these files during un-install):

- C:\Windows\SysWOW64\OpenCL.dll

- C:\Windows\System32\OpenCL.dll

and make sure that the following files are not available in the system. (if they exist, please delete them)

- C:\Windows\System32\IntelOpenCL64.dll

- C:\Windows\SysWOW64\IntelOpenCL32.dll

Finally, try to install again the SDK again (use the following link: .



0 Kudos