OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

opencl_runtime_16.1.2 not for ubuntu

tambellini__william
367 Views

Hi all

On this page:

https://software.intel.com/en-us/articles/opencl-drivers#latest_CPU_runtime

this link is stating both RH and Ubuntu :

but the installer opencl_runtime_16.1.2_x64_rh_6.4.0.37

is not compatible with Ubuntu :

"

Unsupported OS
Detected operating system is not supported. Supported operating systems for this release are:
CentOS* 7 (Intel(R) 64), 7 (Intel(R) 64)
Red Hat Enterprise Linux* 7 (Intel(R) 64), 6.5 (Intel(R) 64), 6.6 (Intel(R) 64)

"

Kind

WT

 

 

 

0 Kudos
2 Replies
Michael_C_Intel1
Moderator
367 Views

Hi WilliamT,

Thanks for the write up and sharing your concern.

Compatible and supported have two different meanings in the context of opencl runtimes matching a particular platform. Centos is an actively supported target, while we still expect Ubuntu 16.04.x to function.

The package you refer to deploys successfully on my Ubuntu 16.04.4 system into /opt/intel/opencl-1.2-6.4.0.37/ .

For latest drivers please refer to:

https://software.intel.com/en-us/articles/opencl-drivers

Please give it a shot and let me know in this thread if there is any more blocking issue.

Thanks,

-MichaelC

 

tambellini__william
367 Views

Ok I will give a new try bypassing the warning.

Thank you.

WT.

Reply