OpenCL* for CPU
Ask questions and share information on Intel® SDK for OpenCL™ Applications and OpenCL™ implementations for Intel® CPU
Announcements
This forum covers OpenCL* for CPU only. OpenCL* for GPU questions can be asked in the GPU Compute Software forum. Intel® FPGA SDK for OpenCL™ questions can be ask in the FPGA Intel® High Level Design forum.
1663 Discussions

Getting Started in Linux with Intel® SDK for OpenCL™ Applications

ameln3
Beginner
354 Views

I followed the instructions here: https://software.intel.com/en-us/articles/sdk-for-opencl-gsg

I have successfully completed all the steps listed above. When running neon.3 eclipse I have got the following message:

"Cannot get platform list:

Could not load required libraries; please make sure to set the correct path under the Code Builder for OpenCL preference page."

python sys_analyzer -v outputs:

"

--------------------------
Hardware readiness checks:
--------------------------
 [ OK ] Processor name: Intel(R) Core(TM) i3-4010U CPU @ 1.70GHz
 [ INFO ] Intel Processor
 [ INFO ] Processor brand: Core
 [ INFO ] Processor arch: Haswell
--------------------------
OS readiness checks:
--------------------------
 [ INFO ] GPU PCI id     : 0A16
 [ INFO ] GPU description: HSW ULT GT2 mobile
 [ OK ] GPU visible to OS
 [ INFO ] no nomodeset in GRUB cmdline (good)
 [ INFO ] Linux distro   : Ubuntu 16.04
 [ INFO ] Linux kernel   : 4.13.0-36-generic
 [ INFO ] glibc version  : 2.23
 [ INFO ] Linux distro suitable for Generic install
 [ INFO ] gcc version    : 20160609 (>=4.8.2 suggested)
--------------------------
Media Server Studio Install:
--------------------------
 [ OK ] user in video group
 [ OK ] libva.so.1 found
 [ ERROR ] libva not loading Intel iHD
 [ OK ] vainfo reports valid codec entry points
 [ INFO ] i915 driver in use by Intel video adapter
 [ OK ] /dev/dri/renderD128 connects to Intel i915
--------------------------
Component Smoke Tests:
--------------------------
 [ ERROR ] no Media SDK include files.  Are Intel components installed?
 [ OK ] OpenCL check:platform:Intel(R) OpenCL GPU OK CPU OK
platform:Experimental OpenCL 2.1 CPU Only Platform GPU OK CPU OK

"

I also successfully able to run

ioc64 -input=simpleAdd.cl -asm

 

What is missing? Do I have to install anything else?

Thank you...

 

 

0 Kudos
4 Replies
Michael_C_Intel1
Moderator
354 Views

Hi AndreyM,

Thanks for the detailed feedback.

This issue appears to addressed in the release notes and called out as the libcurl dependency prereq in the example set up guide. References:

 

If this doesn't map to your issue please attach a screen shot of the error. Either way, can you let us know how it goes?

Thanks,

-MichaelC

ameln3
Beginner
354 Views

Thank you!!!

Let me digest your response :-).

Andrey M.

ameln3
Beginner
354 Views

Dear Michael,

thank you for the updates.

It worked.

Andrey M.

Michael_C_Intel1
Moderator
354 Views

Great deal... thanks for letting us know.

Reply