Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
359 Views

High CPU usage of "system" process with Gameloop Emulator

Jump to solution

Hello everyone!

  • I have been experiencing high cpu usage reaching even 100% with Gameloop Emulator Opened Only.
  • The issue starts after I turn on pc or restart the pc.
  • Issue stays sometimes for first few battles on pubg mobile (duration 45mins to 1.5hours) and sometimes all the way until I want to take a break and turn off pc. Even then it takes few battles for the "SYSTEM" process to show low usage. And when that usage comes down, the emulator eventually also reduces taking up cpu than before.
  • I tried reinstalling windows multiple times, with HDD disconnected and having Window and Emulator installed in SSD.
  • I also tried using different partitions both for windows and emulator.
  • Also tried different versions of emulator with high and low settings but same issue.
  • I have attached screenshots of "USERBENCHMARK" results.
  • I have also tried everything with or without virtualization enabled in BIOS.
  • Sometimes when I simply restart the app "Pubg Mobile" inside Emulator Gameloop beta 7.1 it gets normal. (screenshot named Normal Usage attached).

 

My Specifications:

  • CPU: i5 6600 intel
  • RAM: 16gb DDR4 Corsair
  • SSD: 240gb Gigabyte
  • HDD: 1Tb Seagate
  • Graphics Card: GTX 1070
  • Windows: Windows 10 Home 64bit

Thanks alot.

 

(Email address removed)

0 Kudos

Accepted Solutions
Highlighted
258 Views
Extreme stuttering in the game.

Fortunately the issue was caused by the emulator and has been resolved with the arrival of new update.

View solution in original post

0 Kudos
9 Replies
Highlighted
Super User
357 Views

Remove your email.  It is not necessary, unless you want to get spammed.

0 Kudos
Highlighted
345 Views
And how do I edit the body now? I am unable to do that
0 Kudos
Highlighted
Super User
331 Views

@Glazen_Kraken Whoops....   I forgot that  you cannot edit your posts.  Sorry.

0 Kudos
Highlighted
Super User
329 Views

@Erikal No problem.  We try our best to stop spammers.

0 Kudos
Highlighted
Moderator
318 Views

Hello @Glazen_Kraken

Thank you for posting on the Intel® communities.

 

The CPU utilization increases especially when using heavy applications like games and video streaming or rendering. However, high CPU utilization does not necessarily mean that it is an issue unless it causes performance issues, stuttering in games, input lag, make games unplayable, etc. Besides seeing high CPU utilization, are you experiencing any of these problems? Please provide details.

 

Also, it is worth mentioning that when it comes to games, video playback, encode-decode, 3D applications, etc.; it is expected that those type of applications run on the Graphics Processing Unit (GPU), either an integrated GPU or discrete GPU (of course, it would be also workload on the CPU).

Where there is High CPU utilization (and when GPU utilization is very low or 0%) could be a symptom pointing out an issue with the app or game not able to properly identify and use the resources of the GPU and instead it is running only on the CPU. For this reason, we also recommend checking with the developer team of Gameloop Emulator* to confirm that your system meets the recommended hardware/software/settings requirements.

 

Nevertheless, we would like to gather the following information in order to check this behavior further:

1- Did the system work fine before with Gameloop Emulator*? If yes, was there any recent change (Hardware or Software) that might trigger this behavior?

2- Please provide step-by-step instructions so we can try to reproduce this behavior in our lab.

3- When seeing this "High CPU Utilization" using the Emulator, please take a screenshot from Windows® Task Manager from the Performance Tab showing CPU and GPU(s) utilization.

4- Please provide an Intel® Processor Diagnostic Tool report. You can download the proper version (32 or 64 bit) from the below link:

https://downloadcenter.intel.com/download/19792/Intel-Processor-Diagnostic-Tool

To save the report, once the test is done, click on "File >> View Results File" and attach the .txt file to your reply.

 

5- Also, please run the Intel® System Support Utility (Intel® SSU) and attach the report to this thread to gather more details about your system:

  • Download the Intel® SSU and save the application on your computer: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-
  • Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".
  • To save your scan, click Next and click Save.

Note: Note: To upload and attach a file, use the "Drag and drop here or browse files to attach" option below the response textbox.

 

Best regards,

Andrew G.

Intel Customer Support Technician

 

0 Kudos
Highlighted
284 Views

Hello. Thanks.

The platform having issue (Gameloop) is an emulator hence based mostly on CPU and all the specifications of my system are beyond minimum requirements for this emulator.

The information required is given below.

  1. No the system started this strange behavior without any reason.
  2. Gameloop 7.1 version was started and the required reports are attached. 
  3. Screenshots attached name, Performance Tab TaskManager.
  4. Intel_Processor_Diagnostic_Tool report is attached.
  5. System support utility report is also attached.
0 Kudos
Highlighted
Moderator
270 Views

Hello @Glazen_Kraken

Thank you for your response.

Please allow us to check further this behavior. We will also try to replicate this in our lab. We might be missing specific replication steps from your side (previously requested), for instance: specific app/game settings, specific battles to play, etc.; however, we will try to test this using the versions you mentioned and we will be posting back in the thread either with the outcome of the tests or requesting additional information.


Also, could you please confirm if besides seeing high CPU utilization, are you experiencing any other behavior like performance issues, stuttering in games, lagging?


Best regards,

Andrew G.

Intel Customer Support Technician


0 Kudos
Highlighted
259 Views
Extreme stuttering in the game.

Fortunately the issue was caused by the emulator and has been resolved with the arrival of new update.

View solution in original post

0 Kudos
Highlighted
Moderator
241 Views

Hello @Glazen_Kraken

Thank you for your response.

We are glad to know that the issue has been solved with a new update of the emulator. Hopefully, this information may be useful for other peers experiencing similar behavior.


Since the thread has been marked as "Solved" we will proceed to close it now. If you need any additional information, please submit a new question as this thread will no longer being monitored. It has been a pleasure to assist you.


Sincerely,

Andrew G.

Intel Customer Support Technician


0 Kudos