Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Rhonda99
Beginner
341 Views

Intel CPU CONSTANTLY Throttled to Lowest Frequency - Ubuntu 20.04

I am at my wits end here and could use some additional input. Long story short (more detail below), my system keeps throttling the CPU speed and I am unable to recover until I am able to unplug the battery of my laptop.

-> Description of Problem

Essentially, when all is cooperating, my CPU runs fine. I'm monitoring the CPU speed and usage with Conky and I can observe the frequency multiplier appropriately scaling based upon load. I also observe 'turbo' kick in under high load.

Then, without any discernible reason, my CPU throttles down to it's minimum of 400 MHz and remains at this level indefinitely. This includes after reboots or shutdowns - it will reboot into 400 MHz. If I push the CPU usage to 100% in this mode, it will remain at 400 MHz. I have attempted using cpufrequtils to force the CPU frequency and it does not move (sudo cpufreq-set -f `cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_max_freq). Also attempted resetting the cpufrequtils service with sudo /etc/init.d/cpufrequtils restart and the CPU remains throttled. I've now since removed cpufrequtils hoping that maybe itself was interfering with the CPU, but alas the problem remains. The only reliable method I've been able to use to recover the unit is disconnect the battery for a short period of time (1-2 minutes). As you might imagine, this is quite the pain.

Help?

-> System Info

Kernel: 5.8.0-41-generic

Distro: Ubuntu 20.04.2 LTS

CPU: 11th Gen Intel(R) Core(TM) i7-1185G7 @ 3.00GHz

Laptop Manf: MSI

Laptop Model: Prestige 15 A11SCX-002

-> Output of 'cpupower frequency-info'

analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: Cannot determine or is not supported.
hardware limits: 400 MHz - 4.80 GHz
available cpufreq governors: performance powersave
current policy: frequency should be within 400 MHz and 4.80 GHz.
The governor "powersave" may decide which speed to use
within this range.
current CPU frequency: Unable to call hardware
current CPU frequency: 1.60 GHz (asserted by call to kernel)
boost state support:
Supported: yes
Active: yes
Notes:

(1) I've tried adjusting the governor to performance to no avail - it does not appear to matter regarding the throttling.

(2) I cannot determine a reliable method to reproduce the issue. Sometimes it will throttle 10 minutes after initial boot or 3 hours after initial boot.

(3) I've tried various kernel versions (5.4 & 5.10 namely) and the issue persists.

(4) I've also tried adjusting the CPU driver by disabling via grub with intel_pstate=disable added to the GRUB_CMDLINE_LINUX_DEFAULT env variable. This forces my kernel to default to the acpi-cpufreq driver (confirmed with cpupower). Still the issue persists.

(5) Fast boot is disabled and I have no indications via BIOS that the BIOS is throttling my CPU as well.

0 Kudos
2 Replies
Sebastian_M_Intel
Moderator
47 Views

Hello Rhonda99, 

 

Thank you for posting on the Intel® communities.   

 

I would like to let you know that Intel has not tested/validated Linux OS for Intel CPUs, so we do not provide support for it either. 

 

Our recommendation is to contact your distribution's forum for peer assistance https://ubuntu.com/community  

 

Also, you should contact your system manufacturer (OEM) for additional help as this CPU is installed on a laptop.  

 

Regards, 

 

Sebastian M  

Intel Customer Support Technician  

 

Links to third-party sites and references to third-party trademarks are provided for convenience and illustrative purposes only. Unless explicitly stated, Intel® is not responsible for the contents of such links, and no third-party endorsement of Intel or any of its products is implied.  


Sebastian_M_Intel
Moderator
37 Views

Hello Rhonda99,  

 

We hope our previous recommendations were useful to you.


As mentioned, Intel does not provide support for issues on Linux, so you may want to check with the distro's forum or your OEM.


Based on that, we will close this inquiry. If you need further help, please submit a new thread and we will gladly assist you.

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician