Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MAlra4
Novice
572 Views

So I am currently running my Dell g5 5587 on an i5 8300h. During heavy gaming, I notice significant FPS drops due to CPU power limit. I am really confused and would appreciate any help. Should I undervolt my CPU ? If so how ?

I also would like to know what else could be done to fix this

7 Replies
AlHill
Super User
486 Views

We cannot help you with nvidia graphics. But, nvidia support can.

 

Doc

 

MAlra4
Novice
486 Views

and who said i need help with graphics?

 

 

AlHill
Super User
486 Views

I did. What makes you think you need processor help?

 

Doc

MAlra4
Novice
486 Views

XTU software shows that my cpu is power limiting and also significant drop in Core frequency while im gaming

AlHill
Super User
486 Views

Ah, the plot thickens... You have an H processor. XTU is only for X and K processors.

Uninstall XTU. You cannot rely upon data from a utility not intended for your processor.

Then, reset your bios, if dell allows such a thing, back to their default settiugs.

 

So, it never occurred to you that the problem could be with your dell or your nvidia graphics?

 

Doc

 

n_scott_pearson
Super User Retired Employee
486 Views

Since Al didn't actually say it, I will: Power Limiting, if implemented, is implemented within the BIOS.

 

This is a capability that laptop designers will often use to make up for the crappy batteries and/or inadequate cooling solutions that they have provided. If they've "neglected" to provide any way to configure this feature in BIOS Setup, well, it tells you what you've received. Regardless, this is between you and them.

 

...S

Drkill
Beginner
451 Views

This is what worked for me.

Ever since the Bios update all my games have been lagging. I first thought it was just game servers (as I play a lot of apex legends and the prediction error icon kept popping up) Turns out it was just Dell software.

What's the bug?
It is in the latest bios. And it's almost impossible to downgrade to the older one (1.3 I think) which used to work smoothly. If you do manage to downgrade that will fix the issue.

What I did? (Skip For solution below)

After using GPU and CPU monitoring software (Msi afterburner), I realised that every time the GPU temperature would hit 77% C the GPU would throttle form 100% usage all the way back to 0% -30% usage causing all kinds of game lags for a few seconds.
To fix this I increased my max temperature limit to 87% C. Since this might damage the system over time, I can see what Dell was attempting. what a fail though right?

This stopped lag in a few of my games. But not Apex legends. But when I restarted my system the lag was back forcing itself back to less than 77% C again despite the increased temperature limit (Using third party software) This is also when I noticed that my CPU temp was hitting almost 100% C while gaming (Totally unsafe) So I Disabled turbo boost in the bios settings now realising it was never a hardware issue. It was the laptop that would Throttle the GPU usage all the way down From 100% to 0-19 % percent. The system was attempting to cool itself ever 30sec when it hit 77% C and to achieve this it would cut the GPU usage completely for a few seconds making games unplayable.
I finally set the temperature limit to 76%C. And that solved it. Now there is no more lag and the Max CPU and GPU temperatures don't go over 75%.

To fix the issue just follow these steps:

1) Search for Dell power manager and turn up thermal settings to Ultra performance from optimised. To give Your fans a boost.

2)Turn off turbo mode for the CPU.
Just Restart the PC and press F2 at the Dell logo. Find turbo boost in Bios settings and disable it. (This will significantly reduce CPU temperature as it no longer will overclock the processor unnecessarily)

3) To undo Dells Screw up just download Asus GPU tweak 2 and install it. This will let you Adjust temperature limits for the CPU and GPU. Once installed Go into the advanced options and set max temperature a little less than 77%C ( 72%-76%) as the bug happens when it hits 77C%. (Also you might see over all performance decrease if set under 70%C so I don't suggest it.) Let the software always run.

That's pretty much it. Now all games will run cooler and are lag free. I have tested it on Apex legends and Starwars Jadi fallen order at Max settings and am getting over 70 Fps Consistently.

Thank you.
Tags (1)
Reply