Processors
Processors (Intel® Core™, Intel® Xeon®, etc); processor utilities and programs (Intel® Processor Identification Utility, Intel® Extreme Tuning Utility, Intel® Easy Streaming Wizard, etc.)
12172 Discussions

audio card C230 not detected Ubuntu 20.04

MarcFran
Novice
360 Views

hi,

I run Ubuntu 20.04 on my computer equiped with a C230 chip for the audio. But it looks like the card can not be detected properly. I can not get an analog/digital profile autodetected. Only HDMI profiles are available. It looks like the card is not properly recognized by Ubuntu.Sound is not working on loadspeaker. Have to connect an external TV through HDMI.

Could you help please?

Cheers

list-cards
1 card(s) available.
index: 0
name: <alsa_card.pci-0000_00_1f.3>
driver: <module-alsa-card.c>
owner module: 7
properties:
alsa.card = "1"
alsa.card_name = "HDA Intel PCH"
alsa.long_card_name = "HDA Intel PCH at 0x94320000 irq 132"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1f.3"
sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card1"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "a170"
device.product.name = "100 Series/C230 Series Chipset Family HD Audio Controller"
device.form_factor = "internal"
device.string = "1"
device.description = "Audio interne"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
profiles:
output:hdmi-stereo: Sortie Digital Stereo (HDMI) (priority 5900, available: no)
output:hdmi-surround: Sortie Digital Surround 5.1 (HDMI) (priority 800, available: no)
output:hdmi-surround71: Sortie Digital Surround 7.1 (HDMI) (priority 800, available: no)
output:hdmi-stereo-extra1: Sortie Digital Stereo (HDMI 2) (priority 5700, available: no)
output:hdmi-surround-extra1: Sortie Digital Surround 5.1 (HDMI 2) (priority 600, available: no)
output:hdmi-surround71-extra1: Sortie Digital Surround 7.1 (HDMI 2) (priority 600, available: no)
output:hdmi-stereo-extra2: Sortie Digital Stereo (HDMI 3) (priority 5700, available: no)
output:hdmi-surround-extra2: Sortie Digital Surround 5.1 (HDMI 3) (priority 600, available: no)
output:hdmi-surround71-extra2: Sortie Digital Surround 7.1 (HDMI 3) (priority 600, available: no)
output:hdmi-stereo-extra3: Sortie Digital Stereo (HDMI 4) (priority 5700, available: no)
output:hdmi-surround-extra3: Sortie Digital Surround 5.1 (HDMI 4) (priority 600, available: no)
output:hdmi-surround71-extra3: Sortie Digital Surround 7.1 (HDMI 4) (priority 600, available: no)
output:hdmi-stereo-extra4: Sortie Digital Stereo (HDMI 5) (priority 5700, available: no)
output:hdmi-surround-extra4: Sortie Digital Surround 5.1 (HDMI 5) (priority 600, available: no)
output:hdmi-surround71-extra4: Sortie Digital Surround 7.1 (HDMI 5) (priority 600, available: no)
off: Éteint (priority 0, available: unknown)
active profile: <off>
ports:
hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"
hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
properties:
device.icon_name = "video-display"

0 Kudos
5 Replies
AndrewG_Intel
Moderator
341 Views

Hello @MarcFran

Thank you for posting on the Intel® communities.

In order to provide you with the proper information, could you please confirm the full/exact brand and model of your computer or motherboard? Is this regarding an Intel® Serer or an Intel® NUC?


Best regards,

Andrew G.

Intel Customer Support Technician


MarcFran
Novice
329 Views

Hi Andrew, this is a laptop, Acer Aspire V5-V591. Here are the details. Could you help?

I have tried to look at how the intel hardware is detected by Ubuntu - especially the C230, but i am not sure how it is being supported.

Advise would be welcome,

Cheers

## Scanned Hardware
Computer:
BaseBoard Manufacturer:"Acer"
Bios Mode:"UEFI"
Bios Version/Date:"V1.15,10/19/2017"
CD or DVD:"Not Available"
Platform Role:"Linux marc-Aspire-V5-591G 5.8.0-50-generic #56~20.04.1-Ubuntu SMP Mon Apr 12 21:46:35 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux"
Processor:"Intel(R) Core(TM) i5-6300HQ CPU @ 2.30GHz"
SMBIOS Version:"2.8"
Sound Cards:"HDA-Intel - HDA Intel PCH"
Sound Cards:"HDA Intel PCH at 0x94320000 irq 132"
System Manufacturer:"Acer"
System Model:"Aspire V5-591G"
System Type:"x64-based PC"

- Motherboard
Manufacturer:"Acer"
Product:"Usopp_SLS"

- Processor
- "Intel(R) Core(TM) i5-6300HQ CPU @ 2.30GHz"
Architecture:"x86_64"
Available:"Offline"
Byte Order:"Not Available"
Cache Size:"6144 KB"
Caption:"Intel(R) Core(TM) i5-6300HQ CPU @ 2.30GHz"
- Characteristics
64-bit capable
Enhanced Virtualization
Execute Protection
Multi-Core
Power/Performance Control
CPU Speed (Minimum):"2826.564"
CPU Speed (Maximum):"2300 MHz"
Current Voltage:"0.9 V"
External Clock:"100 MHz"
Family:"Core i5"

AndrewG_Intel
Moderator
316 Views

Hello MarcFran

Thank you for the information provided.


We are still checking this and we would like you to confirm some additional details:


1- Just to make sure, this "audio card C230" is the one that works through "3.5mm jack" connectors on the computer? For instance, where you plug headphones/speakers. Is this correct? If not, could you please provide more details?

2- Could you please confirm what is the exact model of the Intel Chipset in the computer? We were looking for this information but we were not able to find it on the Acer* website.

3- Have you checked this with UBUNTU* Support? For instance, checking UBUNTU* Forums we see topics that might relate to this topic: Ubuntu 20.04 - No sound.


Please note that audio functionality through audio jack connectors (if this is the one you are using) also depends on the customizations performed by the computer manufacturer (OEM) and we would not be aware of those customizations so it is also recommended to check this further with your OEM Acer*.


Best regards,

Andrew G.

Intel Customer Support Technician


MarcFran
Novice
307 Views

hi Andrew,

 

Yes the C230 card is the one that works with the audio jack and loud speaker. What ever I do i got only a dummy device. I can not get the computer to recognize an other output other than the dummy one and the HDMI.

Here is the output of the alsa diag.

!!Soundcards recognised by ALSA
!!-----------------------------

 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0x94320000 irq 132


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.3 Audio device [0403]: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller [8086:a170] (rev 31)
	Subsystem: Acer Incorporated [ALI] 100 Series/C230 Series Chipset Family HD Audio Controller [1025:1033]

 

I have been checking all possible Ubuntu and Linux forums for weeks now. Nothing works. I have logged a ticket in https://answers.launchpad.net/ubuntu but despite all advises no solution has been found so far. I have upgraded Ubuntu on 20.1 just in case. I am really running out of options. I would like to know how to get the sound card recognized as a physical output.

 

Cheers

AndrewG_Intel
Moderator
283 Views

Hello MarcFran

Thank you for your response.


After checking this further, it is worth mentioning that we only provided Intel® Chipset Software and related links to drivers for Intel® Server Boards, Intel® Server Systems, and Intel® NUCs. For pre-built systems or third-party motherboards, the recommendation is to contact the Original Equipment Manufacturer for the latest updates and technical support information, in this case, ACER* Support. This recommendation is also important considering the previous facts we shared regarding that we would not be aware of the customizations performed by the OEM Acer*, so the ones that handle all the technical information and should provide the proper assistance is your OEM. At this point, the best channel of support is through Acer*.


Having said that, we will proceed to close this inquiry now. If you need any additional information, please submit a new question as this thread will no longer be monitored. Thank you for your understanding.


Best regards,

Andrew G.

Intel Customer Support Technician


Reply