Processors
Intel® Processors, Tools, and Utilities
14674 Discussions

w5-3435X: Massive lagg on Windows 11 with power plan "Balanced"

flobernd
Novice
3,996 Views
Hi there, I just upgraded my system from a X299 platform to W790 and a Intel Xeon w5-3435X core and immediately noticed a massive UI lagg/stuttering when moving windows or trying to select something in the Windows explorer. This only happens when the CPU is idling and the frequency got lowered. As soon as there is some background activity, the lagg disappers. After this observation, I switched the power plan from "Balanced" to "Performance" and voilla, system suddenly is snappy again. Obviously I don't want to disable this useful power-saving feature completely... Is there anything I could try to get it working? Board: Asus PRO WS W790E-SAGE SE BIOS Version: 0215 (latest)
0 Kudos
14 Replies
Allan_A_Intel
Moderator
3,949 Views

Hello, flobernd,


Thank you for reaching Intel Communities. I will gladly help you.


The type of behavior that you mention seems to be expected some times. I found an article from Microsoft* with a similar situation where it explains a similar behavior will happens sometimes and that one way to fix it is by changing the power plan to High Performance: https://learn.microsoft.com/en-us/troubleshoot/windows-server/performance/slow-performance-when-using-power-plan


I would say that it is an expected behavior that might change depending on the system's configuration and activity, but I recommend you contacting Asus* to confirm if the version of Windows* installed in your system is validated for your motherboard and properly updated. They may also have additional recommendations of what driver or firmware to install and/or update: https://www.intel.com/content/www/us/en/support/contact-intel.html?tab=system-manufacturers


Best regards,

Allan


0 Kudos
flobernd
Novice
3,920 Views
Hi Allan,

thanks for your answer!

I found this article as well, but sadly it does not provide any helpful information for my situation. I wouldn’t call it „expected behavior“ as the Microsoft article clearly mentions hotfixes.

It’s a fairly new platform which makes me guess that we might have a bug here in either the Intel ME, the BIOS or Windows 11.

Maybe you could internally check if this is a known problem? In the meantime I will reach out to ASUS and check if they have a solution.
0 Kudos
Allan_A_Intel
Moderator
3,898 Views

Hello, flobernd,


Could you please let me know why you believe that could be related to Intel® Management Engine? Because if it is, then you can post your concern in the forum related to it: https://community.intel.com/t5/Intel-vPro-Platform/bd-p/vpro-platform


For a possible bug in the BIOS, you would need to contact ASUS, and for a possible bug in Windows, you will need to contact Microsoft.


From my part, besides checking with ASUS and/or Microsoft, I can only suggest testing with another processor in the same system. If the behaviour persists, very likely it would mean that it is not related to the processor.


Best regards,


0 Kudos
flobernd
Novice
3,879 Views
Hi Allan,

this is just a wild guess. If I’m not mistaken the Intel ME as well plays a part in the whole Turbo Mode/Speedstep/3.0 topic.

I already contacted ASUS and awaiting their answer.
0 Kudos
rjsss
Beginner
3,777 Views

Seeing a similar problem with a 3495x on an ASUS pro-ws w790e-safe se.  

 

In balanced or power saver the system becomes so sluggish as to be nearly unusable.  In high performance mode everything works fine except for an idle power consumption about 100w higher.  

0 Kudos
flobernd
Novice
3,757 Views

I'm sorry to hear that you have the same issue. On the other hand I'm glad to see that it's not limited to my specific hardware and seems to affect at least other ASUS W790 board + w34** chip combinations. Would be interesting  to see if it's limited to ASUS boards or if it's the chipset+cpu generation in general.

 

German ASUS support told me they have to investigate the issue in Taiwan. Will update you about their answer as soon as I get one (I don't expect it to happen too soon).

0 Kudos
rjsss
Beginner
3,734 Views

I've done a bit of digging here to figure out some of what is happening.  It's not related to reported clock speed from the CPU.  It's also only worked around by the legacy power plans in windows.  If you change the new windows "power mode" it does not work around the issue.

 

I used the old power plan to force the CPU to higher clock speeds in balanced and allow lower ones in max performance.  Both continued to work the same.  Interestingly there is a 100w in cpu idle power when the plan is switched.  I thought this was from the higher idle clocks.  This doesn't appear to be the case as changing the clocks via the power plan had little effect on this.

 

I also benchmarked build times in Visual Studio.  The project I'm working on used to take about 30s on the old w2275, and now about 24s in max performance mode.  In balanced it spikes to 56s, worse than the old workstation and even worse than a 5 year old laptop.  This is clearly a bug somewhere.  

0 Kudos
flobernd
Novice
3,722 Views
Yes it’s clearly a bug. The only question is if it’s an Intel, Asus, Windows, etc. bug

Intel does not seem to be interested in further investigation it seems, based on the last official answer here.

Asus is investigating at least and Windows… well, after 1 hour of support chat, their solution was the workaround that I told them in the beginning (set min CPU to 100%)… I don’t expect any help from that side.
0 Kudos
rjsss
Beginner
3,716 Views

Agreed, 

I found a 2nd workaround which was to set the p-state control to "out of band" in the BIOS.  That allows the CPU to ignore the advice from the OS and do it's own thing.  This produced what you would normally expect from "balanced".  i.e. low idle consumption while still being reasonably responsive.  It's still very conservative clocking up for a workstation, this tuning looks optimized for server.  

 

If your bios has that option you may want to give it a try.  Downside is it removed the ability to control things from in the OS.

 

This seems like an ASUS problem.  An OS shouldn't need to fine tune the power management, that's a bios/drivers job.  I've pinged the system builder and will also keep investigating here.

0 Kudos
flobernd
Novice
3,686 Views

Can you confirm that your power usage is lower when using "out of band"? I tested this option as well and, like you said, it definitely improves responsiveness in Windows a lot, but  I noticed that my idle power consumption while using "out of band" P-States was still the same than using "native" P-states and the "High Performance" power plan (this surprised me; but I didn't check in detail).

This workaround will probably as well affect single-core performance quite a lot as the "Intel Turbo Boost 3.0" technology needs OS assistance and can not work in "out of band" mode.

From my understanding, the BIOS/some EFI driver controls power states in the beginning, but hands over to the OS as soon as a ACPI aware OS is started. The "native" P-States are BIOS/EFI controlled BUT they take guidance from the OS (respectively the Intel Chipset driver installed on the OS). Both components are playing a role here (and potentially some others like Intel ME are involved, but I'm not sure about this). Only when using "out of band", P-states should be entirely controlled by the BIOS/EFI.

Anyways.. let's wait for the investigation results It's good that you pinged your system builder as well. The more people raise the problem, the higher priority it hopefully gets. I feel like a beta tester for this platform at the moment.

0 Kudos
rjsss
Beginner
3,669 Views

Yes, I was seeing lower power numbers in "out of band".  

 

I've never seen this system hit Turbo-2 or -3 speeds on limited thread counts.  I also have an open issue with the builder for this.  It's fine for multi-core turbo.

0 Kudos
ShirouzuH
Beginner
2,691 Views

I am having the same problem with a w5-3425X + Supermicro MB(X13SWA-TF).
I would like to know if you have received an answer from Intel or ASUS.

What I noticed here is that among the hidden parameters in the power plan, PERFBOOSTPOL and PERFEPP are working.
(they are shown in powercfg /qh)

In the "balanced" power plan, especially if the value of PERFBOOSTPOL is set to 100 or higher, the response is improved.
However, it also increases power consumption.

 

My solution is to create a resident app that changes to the "Performance" power plan (minimum clock set to 1%) for 5 seconds after mouse and keyboard input occurs.
I wish there was a better way.

 

Best regards,

 

ShirouzuH, from Japan

0 Kudos
gridth
Beginner
2,655 Views

I'm able to fix my slowness issue with X13SWA-TF + w9-3495X by going to:

CPU ConfigurationAdvanced Power Management Configuration → Set the following settings:

  • Power Technology: Custom
  • Power Performance Tuning: BIOS Controls EPB
  • ENERGY_PERF_BIAS_CFG: Maximum Performance

Setting this will make the BIOS stop handing over Energy Performance Bias control to the OS and instead use a fixed value. This has fixed all my issues with sluggishness with running "Balanced" power profile on Windows and "powersave" governor on Linux (and idles at 50W).

0 Kudos
ShirouzuH
Beginner
2,614 Views

Thanks for the information.
I tried it on Win10 at hand and the lag is gone.

 

According to HWiNFO64, the idle power consumption increased from 60w to 80w in "balace" plan.
But, it is better than the 100w when in "Performance" plan.

 

Thank you!

0 Kudos
Reply