Community
cancel
Showing results for 
Search instead for 
Did you mean: 
CLoon1
Beginner
804 Views

Altera Cyclone II Quartus II JTAG Programming Error

'm trying to program a Cyclone II I bought here using Quartus II 13.0sp1 on Arch Linux. I'm trying to program it with a very simple Verilog program with three inputs and two outputs and a few simple logic functions. I selected the proper model (EP2C5T144C8), assigned the pins to the inputs/outputs, compiled, and ran the programmer. I am using a JTAG USB blaster. When I run jtagconfig, I receive the following output

1) USB-Blaster [2-1.6]   020B10DD EP2C5

 

However, when I try to program the .sof file created by the compiler, I receive the following error.

Error (209015): Can't configure device. Expected JTAG ID code 0x020B10DD for device 1, but found JTAG ID code 0x000310D9.

 

If I run the programmer multiple times, I often get different values for the ID code that it found. Does anyone know what's wrong here?

 

0 Kudos
1 Reply
JScho6
Novice
99 Views

Check the pull up/down resistors on the JTAG lines of the chip, and possibly reduce the length of the JTAG cable that runs between the board and the USB Blaster. The different ID codes that you're seeing point to a ringing problem on the data line(s).

 

greetings from Germany,

Jens

Reply