Programmable Devices
CPLDs, FPGAs, SoC FPGAs, Configuration, and Transceivers
20676 Discussions

Arria 10 IBIS AMI model selector for supporting VOD setting 12.

Vincent222
Beginner
623 Views

Hello,

 

I had arria 10 IBIS_AMI model and try to simulate transceiver output with "A10_V12_R100_SLEW4" model selector option.

 

I am using HyperLynx.

By the excel file(arria-10-cyclone-10gx-pre-emphasis-and-output-swing-settings.xlsx) from Intel, I expect 330mVp-p output w/o no pre and post tap.

But I always have 1Vp-p at the transceiver output with HyperLynx tool.

 

please let me know how I could have consistent result between excel file and Arria10 IBIS-AMI with HyperLynx.

0 Kudos
7 Replies
Vincent222
Beginner
583 Views

Vincent222_0-1677279231708.jpeg

the eye diagram from hyperlynx is above and always have the same amplitude.

0 Kudos
Kshitij_Intel
Employee
554 Views

Hi,


Can you please confirm, are you using the latest IBIS-AMI model mentioned in the link below.


https://www.intel.in/content/www/in/en/support/programmable/support-resources/board-layout/ibs-ibis-index.html


If yes, please share your IBIS-AMI Model folder and the spreadsheets you are using.


Thank you

Kshitij Goel


0 Kudos
Vincent222
Beginner
540 Views

I am using version 2.0,  file name arria10_gxgt_hssi_ibis_ami_v2p0. my reference excel sheet is attached.

I am comparing the amplitude of excel file and IBIS_AMI model output.

 

Vincent222_0-1677530050410.png

 

0 Kudos
Kshitij_Intel
Employee
512 Views

Hi Vincent,


There is a possibility the VOD has not been set as 12 even though you are setting it. Please check once are you correctly setting the VOD, VCCT and data rate?


Thank you

Kshitij Goel


0 Kudos
Kshitij_Intel
Employee
454 Views

Hi,


As we do not receive any response from you on the previous answer that we have provided. Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.

 

Thank you

Kshitij Goel


0 Kudos
Vincent222
Beginner
442 Views

I set VCCT, VCC and data rate correctly and changed VOD by selecting corresponding model by model selector.

But I could not have any difference.

 

DO you have any sim result with this IBIS_AMI model in any simulator to clarify the VOD amplitude?

 

Vincent222_0-1678389589440.png

eye diagram with A10_V31_R100_SLEW_5 are below..

Vincent222_5-1678389726588.png

 

Vincent222_1-1678389600347.png

Vincent222_3-1678389621506.png

 

eye diagram with A10_V12_R100_SLEW_5 are below..

Vincent222_4-1678389719784.png

 

 

0 Kudos
Vincent222
Beginner
402 Views

Hello K**bleep**ij,

DO you have any feedback?

0 Kudos
Reply