Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
935 Views

Nios ii

Hello,  

 

Help Please! 

 

I' m new in NIOS II and I try to follow this tutorial in youtube" https://www.youtube.com/watch?v=w82xFo1RNmo

but this error appear : 

 

collect2.exe: error: ld returned 1 exit statusmake: *** [led.elf] Error 1 

 

My board is FPGA CYCLONE V : 5CSEMA5F31  

There is an attachement for more details! 

 

THANKS
0 Kudos
10 Replies
Altera_Forum
Honored Contributor I
53 Views

Hi, 

 

1. Select latera on-chip memory size in QSYS. 

Don't forget to re-generate the code in QSYS and re-compile in Quartus. 

or 

2. Select the "small hello world" template to create a new project or from BSP Editor enable the checkbox enable_small_c_library. 

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance. 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
53 Views

Hello , 

yeah I change the program because aia need a timer application . 

so I try to implement counter but it still the same problem  

I change my memory size but it gives me an error so I kept 4096  

 

I found the bsp editor empty in eclipse 

there are some attechment for more details. 

 

Thank you for help. 

 

 

Best regards, 

Imen.
Altera_Forum
Honored Contributor I
53 Views

Hi, 

 

Eclipse may not have loaded the .sopcinfo file correctly because of which you are not able to see the options from BSP Editor. 

Refer the attached for steps. 

 

If you face the same problem deleted the incremental_db, db folder and software folder. Compile qsys design and create new eclipse project.  

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance. 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
53 Views

yes I did all those instruction but it failed  

keep give ;e this error  

collect2.exe: error: ld returned 1 exit status 

make: *** [Keep_working.elf] Error 1 

I dont knoz how can I resolve to go on My project  

 

Thank you for your help  

best Regards
Altera_Forum
Honored Contributor I
53 Views

Hi, 

 

Which version of Quartus and Eclipse are you using? 

And elaborate the steps you have followed for creating a project. (because video link you have shared does not give complete steps) 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
53 Views

thank u. 

It work with me  

 

BestRegards  

Imen.
Altera_Forum
Honored Contributor I
53 Views

Hi, 

I have an other question please  

I try to run the counterbinary (library)  

I build the qsys and my code eclipse every thing is good  

I saw result in console of eclipse but nothing work in my FPGA  

What is the problem Please help me 

 

There qre some attachement
Altera_Forum
Honored Contributor I
53 Views

Hi, 

 

Images are not clear can you reattach the images. If possible attach the project too.  

 

What do you mean?  

Eclipse results are from FPGA only, If it works on eclipse console than it means FPGA is working fine. 

Elaborate the steps and you c/c++ code? 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
53 Views

Hello  

 

I cant thank you enough for your help. 

 

I am tying to do an application like a timer so I need to use the seven segment that s why I begin with using the counter binary  

and it worked in console. the code runing in the console of eclipse but is not in my card.maybe because I dont have to use lcd . 

 

this is my project.there are some photos but I dont know how can I send all my project. 

but the code is the binary count of library, qsys and console there are attachement .
Altera_Forum
Honored Contributor I
53 Views

pleaaaase help me  

I try to simplify my code just for seven segment but nothing happen in my board . 

 

this is my code : 

# include "count_binary.h" 

 

 

/* Seven Segment Display PIO Functions  

* sevenseg_set_hex() -- implements a hex digit map. 

*/ 

 

 

# ifdef SEVEN_SEG_PIO_BASE 

static void sevenseg_set_hex(int hex) 

static alt_u8 segments[16] = { 

0x81, 0xCF, 0x92, 0x86, 0xCC, 0xA4, 0xA0, 0x8F, 0x80, 0x84, /* 0-9 */ 

0x88, 0xE0, 0xF2, 0xC2, 0xB0, 0xB8 }; /* a-f */ 

 

unsigned int data = segments[hex & 15] | (segments[(hex >> 4) & 15] << 8); 

 

IOWR_ALTERA_AVALON_PIO_DATA(SEVEN_SEG_PIO_BASE, data); 

# endif 

 

 

/* static void count_sevenseg() 

*  

* Display value of 'count' on the Seven Segment Display 

*/ 

 

static void count_sevenseg() 

# ifdef SEVEN_SEG_PIO_BASE 

sevenseg_set_hex(count); 

# endif 

 

 

 

int main(void){ 

 

int __attribute__ ((unused)) wait_time; /* Attribute suppresses "var set but not used" warning. */ 

 

int count = 0; 

 

/* Continue 0-ff counting loop. */ 

 

while( 1 )  

usleep(100000); 

count_sevenseg(); 

/* 

* If done counting, wait about 7 seconds... 

* detect button presses while waiting. 

*/ 

if( count == 0xff ) 

printf("\nWaiting..."); 

usleep(100000); /* Sleep for 0.1s. */ 

 

count++; 

 

return 0 ; 

}
Reply