Community
cancel
Showing results for 
Search instead for 
Did you mean: 
GSzak1
Beginner
198 Views

Why would making a minor change in RTL cause the serial flash loader to fail?

I have a project that has worked well for some time, but occasionally I will get a build where the .sof file will not allow me to program the attached EPCQ256. I have not changed any project settings, only RTL to use a different output clock for logic totally unrelated to the flash loader. In most cases, everything works fine. However in one configuration if I have that .sof loaded I get "Error (209025): Can't recognize silicon ID for device 1." If I load a different .sof file, I can program the flash OK and that version works from flash. The MSEL pins are permanently set with resistors to 10011. Also worth noting is that the current build has no SignalTap cores inserted, and the working vs nonworking versions have all the same pin connections as well. I'm building with Quartus 18.1 lite edition, and using Quartus programmer 16.1 for programming with a USB Blaster. Part is a Cyclone 5 GX, 5CGXFC9E6F31.

Any ideas what might cause the problems with programming the flash?

0 Kudos
1 Reply
YuanLi_S_Intel
Employee
34 Views

Hi Gabor,

 

This error messages means that the device selected is not correct. By right it shouldnt be a problem if everything is the same with just some minor RTL changes.

 

Another thing is that, have you tried to generate using the other version of quartus? is it having the similar problem?

 

Thank You.

Reply