Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ZLu001
Novice
597 Views

how to configure Cyclone V and EPCS64

I asked this question before, so far no solution. I'll try to repeat the question and describe my recent effort on it and seek help.

1.     My connection is exactly as figure1.

 

2.   The connections are show at figure2

3.     When configure the device by .sof file using USB Blaster download cable, it works fine and checksum number shows 03063719, usercode shows 0064323C , figure 5 shows the screen shot.

 

4.      When loaded my .jic file to programmer window, checksum shows "0064323C", usercode shows " FFFFFFFF" as in figure 3

A error message is shown after a failed programming: Error (209025): Can't recognize silicon ID for device 1. A device's silicon ID is different from its JTAG ID.

I found the Jtag ID on cyclone IV shows "020F40DD", on cyclone V shows "02B150DD", but don't know how to force the silicon number change to the same number as Jtag ID.

 

5.     I make sure the MSEL{4:0}=10010, and tried 10011.

No difference for the progress.

 

6.     I create my own SFL image and instantiated it into my design, recompile and reload, the programming window is the same and still shows Factory default enhanced SFL image, not my created.

 

7. a successful programming window for cyclone IV is referenced here in figure 4, where checksum and usercode are all "00224CC7", so I believe these two number suppose to be same.

 

After all. 

I know the user code can be set in "device and pin option", but just not sure what code should be put in, because when used in cyclone IV, they have same code as checksum, I uncheck the" auto usercode" and put checksum number 0064323C in the usercode box, but nothing changed after recompile and reload the .jic file.

 

Thank any who can help or give some suggestion.

I have wasted 5 months for this. I can pay for your time if anybody can help.

Thanks, Thanks.

 

0 Kudos
3 Replies
AnandRaj_S_Intel
Employee
62 Views

Hi,

 

Since you can program sof file successfully.

This may be because of configuration file or signal integrity related issues. You can try to monitoring the flash and jtag signals which will help to find the exact cause of the problem. 

 

  1. Can you please check if the Flash part number in schematic, hardware are same.Also use correct flash device while converting .sof to .jic.
  2. Delete the db, increment db and output folder and run full compilation.
  3. While programming .jic, use jtag header and jtag mode.
  4. Try to change the tck frequency and check.

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance.

 

Regards

Anand

ZLu001
Novice
62 Views

Hi, Anand

Thank you very much. I tried all you mentioned, but no improvement at all.

I was going back to Cyclone IV to meet our urgent need and will come back to solve this problem later.

If you have any suggestion, let me know.

 

Thanks again.

 

Zen

 

AnandRaj_S_Intel
Employee
62 Views

Hi Zen,

 

Have you solved the problem?

Kindly share the solution by posting in forum which will help other users too.

 

Regards 

Anand

 

Reply